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Precision Software Technologies, Inc                                          January 1, 2016
END USER LICENSE AGREEMENT FOR THE EZ-SCAN® FAMILY OF SOFTWARE PRODUCTS.
 
IMPORTANT READ CAREFULLY: This End-User License Agreement ("EULA") is a legal agreement between
you (either an individual person or a single legal entity, who will be referred to in this EULA as "You") and
the Licensor for the Precision Software Technologies, Inc who will be referred to in this EULA as "PST")
software technology that displays this EULA, including any associated media, printed materials and electronic
documentation (the "Software"). The Software also includes any software updates, add-on components, web
services and/or supplements that the Licensor may provide to You or make available to You after the date
You obtain Your initial copy of the Software to the extent that such items are not accompanied by a separate
license agreement or terms of use. By installing, copying, downloading, accessing or otherwise using the
Software, You agree to be bound by the terms of this EULA. If You do not agree to the terms of this EULA, do
not install, access or use the Software.

SOFTWARE LICENSE
The Software is protected by intellectual property laws and treaties. The Software is licensed, not sold.

1. GRANT OF LICENSE. This EULA grants You the following permissions:

The LICENSEE is granted permission to use one registered copy of the core scanning licensed SOFTWARE for
one PC, by one User.
This EULA does not grant permission to use core scanning SOFTWARE PRODUCT on more than one PC and one
User at a time.
The LICENSEE is granted permission to use registered copies of the viewing software of the core scanning
licensed SOFTWARE for as many users as needed but must own at lease one core scanning product.
The LICENSEE MUST NOT reproduce, distribute or make any copies of this SOFTWARE, or any of the
accompanying material, for any purpose, except for making ONE copy for the LICENSEE’S own use - for
backup purposes only.
You may not sell, license or distribute copies of the Software on a stand-alone basis or as part of any
collection, product or service.
2.  DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS.

• Limitations on Reverse Engineering, Decompilation, and Disassembly. You may not reverse
engineer, decompile, or disassemble the Software, except and only to the extent that such activity
is expressly permitted by applicable law notwithstanding this limitation.
 

• Trademarks. This EULA does not grant You any rights in connection with any trademarks or
service marks of Licensor or its suppliers.
 

• Support Services. Licensor may provide You with support services related to the Software
("Support Services"). Use of Support Services is governed by the policies and programs described
in the user manual, in "online" documentation, or in other materials from the support services
provider. Any supplemental software code provided to You as part of the Support Services
are considered part of the Software and subject to the terms and conditions of this EULA. You
acknowledge and agree that Licensor may use technical information You provide to Licensor as part
of the Support Services for its business purposes, including for product support and development.
Licensor will not utilize such technical information in a form that personally identifies You. For
Software licensed from the hardware manufacturer, please refer to the manufacturer's support
number and address provided in Your hardware documentation.
 

• Termination. Without prejudice to any other rights, Licensor or its suppliers may terminate this
EULA if You fail to comply with the terms and conditions of this EULA. In such event, You must
destroy all copies of the Software and all of its component parts.



 

 

 

1. INTELLECTUAL PROPERTY RIGHTS. All title and intellectual property rights in and to the
Software (including but not limited to any images, photographs, animations, video, audio, music,
text, and "applets" incorporated into the Software), the accompanying printed materials, and any
copies of the Software are owned by Licensor or its suppliers. All title and intellectual property
rights in and to the content that is not contained in the Software, but may be accessed through
use of the Software, is the property of the respective content owners and may be protected by
applicable copyright or other intellectual property laws and treaties. This EULA grants You no rights
to use such content. If this Software contains documentation that is provided only in electronic
form, you may print one copy of such electronic documentation. You may not copy the printed
materials accompanying the Software. All rights not specifically granted under this EULA are
reserved by Licensor and its suppliers.
 

2. U.S. GOVERNMENT LICENSE RIGHTS. All Software provided to the U.S. Government pursuant to
solicitations issued on or after December 1, 1995 is provided with the commercial license rights and
restrictions described elsewhere herein. All Software provided to the U.S. Government pursuant to
solicitations issued prior to December 1, 1995 is provided with RESTRICTED RIGHTS as provided for
in FAR, 48 CFR 52.227-14 (JUNE 1987) or DFAR, 48 CFR 252.227-7013 (OCT 1988), as applicable.
 

3. EXPORT RESTRICTIONS. You acknowledge that the Software is subject to U.S. export
jurisdiction. You agree to comply with all applicable international and national laws that apply to the
Software, including the U.S. Export Administration Regulations, as well as end-user, end-use and
destination restrictions issued by U.S. and other governments.
 

4. APPLICABLE LAW. If you acquired this Software in the United States, this EULA is governed
by the laws of the State of Florida. If you acquired this Software in Canada, unless expressly
prohibited by local law, this EULA is governed by the laws in force in the Province of Ontario,
Canada; and, in respect of any dispute which may arise hereunder, you consent to the jurisdiction
of the federal and provincial courts sitting in Toronto, Ontario. If this Software was acquired outside
the United States, then local law may apply.
 

5. LIMITED WARRANTY
 
NOTE: IF YOU LICENSED THE SOFTWARE FROM A HARDWARE MANUFACTURER AS A COMPONENT
OF A  SOFTWARE PRODUCT, PLEASE REFER TO THE LIMITED WARRANTIES, LIMITATION OF
LIABILITY, AND OTHER SPECIAL PROVISION APPENDICES PROVIDED WITH OR IN SUCH OTHER
  SOFTWARE PRODUCT. SUCH LIMITED WARRANTIES, LIMITATIONS OF LIABILITY AND SPECIAL
PROVISIONS ARE AN INTEGRAL PART OF THIS EULA AND SHALL SUPERSEDE ALL OF THE
WARRANTIES, LIMITATIONS OF LIABILITY AND OTHER SPECIAL PROVISIONS SET FORTH BELOW.
 

FOR SOFTWARE LICENSED FROM PRECISION SOFTWARE TECHNOLOGIES, INC, THE FOLLOWING SECTIONS
APPLY:
LIMITED WARRANTY FOR SOFTWARE ACQUIRED IN THE US AND CANADA. PST warrants that the Software will
perform substantially in accordance with the accompanying materials for a period of ninety (90) days from the
date of receipt.
If an implied warranty or condition is created by your state/jurisdiction and federal or state/provincial
law prohibits disclaimer of it, you also have an implied warranty or condition, BUT ONLY AS TO DEFECTS
DISCOVERED DURING THE PERIOD OF THIS LIMITED WARRANTY (NINETY DAYS). AS TO ANY DEFECTS
DISCOVERED AFTER THE NINETY (90) DAY PERIOD, THERE IS NO WARRANTY OR CONDITION OF ANY KIND.



 

 

Some states/jurisdictions do not allow limitations on how long an implied warranty or condition lasts, so the
above limitation may not apply to you.
 
Any supplements or updates to the Software, including without limitation, any (if any) service packs or hot
fixes provided to you after the expiration of the ninety (90) day Limited Warranty period are not covered by
any warranty or condition, express, implied or statutory.
LIMITATION ON REMEDIES; NO CONSEQUENTIAL OR OTHER DAMAGES. Your exclusive remedy for any breach
of this Limited Warranty is as set forth below. Except for any refund elected by PST, YOU ARE NOT ENTITLED
TO ANY DAMAGES, INCLUDING BUT NOT LIMITED TO CONSEQUENTIAL DAMAGES, if the Software does not
meet PST’s Limited Warranty, and, to the maximum extent allowed by applicable law, even if any remedy fails
of its essential purpose. The terms of Section 11 below ("Exclusion of Incidental, Consequential and Certain
Other Damages") are also incorporated into this Limited Warranty. Some states/jurisdictions do not allow
the exclusion or limitation of incidental or consequential damages, so the above limitation or exclusion may
not apply to you. This Limited Warranty gives you specific legal rights. You may have others which vary from
state/jurisdiction to state/jurisdiction.
 
YOUR EXCLUSIVE REMEDY. PST’s and its suppliers' entire liability and your exclusive remedy shall be, at PST’s
option from time to time exercised subject to applicable law, (a) return of the price paid (if any) for the Software,
or (b) repair or replacement of the Software, that does not meet this Limited Warranty and that is returned
to PST with a copy of your receipt. You will receive the remedy elected by PST without charge, except that
you are responsible for any expenses you may incur (e.g. cost of shipping the Software to PST). This Limited
Warranty is void if failure of the Software has resulted from accident, abuse, misapplication, abnormal use or
a virus. Any replacement Software will be warranted for the remainder of the original warranty period or thirty
(30) days, whichever is longer. Outside the United States or Canada, neither these remedies nor any product
support services offered by PST are available without proof of purchase from an authorized international source.
To exercise your remedy, contact: Precision Software Technologies, Inc./23110 State Road 54  #326/ Lutz, FL
33549.

LIMITED WARRANTY FOR SOFTWARE ACQUIRED OUTSIDE THE US AND CANADA. FOR THE LIMITED
WARRANTIES AND SPECIAL PROVISIONS PERTAINING TO YOUR PARTICULAR JURISDICTION, PLEASE REFER
TO YOUR WARRANTY BOOKLET INCLUDED WITH THIS PACKAGE OR PROVIDED WITH THE SOFTWARE
PRINTED MATERIALS.
 

1. DISCLAIMER OF WARRANTIES. The Limited Warranty that appears above is the only express
warranty made to you and is provided in lieu of any other express warranties (if any) created by
any documentation or packaging. Except for the Limited Warranty and to the maximum extent
permitted by applicable law, PST and its suppliers provide the Software and support services (if
any) AS IS AND WITH ALL FAULTS, and hereby disclaim all other warranties and conditions, either
express, implied or statutory, including, but not limited to, any (if any) implied warranties, duties
or conditions of merchantability, of fitness for a particular purpose, of accuracy or completeness
of responses, of results, of workmanlike effort, of lack of viruses, and of lack of negligence, all
with regard to the Software, and the provision of or failure to provide support services. ALSO,
THERE IS NO WARRANTY OR CONDITION OF TITLE, QUIET ENJOYMENT, QUIET POSSESSION,
CORRESPONDANCE TO DESCRIPTION OR NON-INFRINGEMENT WITH REGARD TO THE SOFTWARE.
 

1. EXCLUSION OF INCIDENTAL, CONSEQUENTIAL AND CERTAIN OTHER DAMAGES. 
  TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL PST OR
ITS SUPPLIERS BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR CONSEQUENTIAL
DAMAGES WHATSOEVER (INCLUDING, BUT NOT LIMITED TO, DAMAGES FOR LOSS OF PROFITS
OR CONFIDENTIAL OR OTHER INFORMATION, FOR BUSINESS INTERRUPTION, FOR PERSONAL



 

 

INJURY, FOR LOSS OF PRIVACY, FOR FAILURE TO MEET ANY DUTY INCLUDING OF GOOD FAITH
OR OF REASONABLE CARE, FOR NEGLIGENCE, AND FOR ANY OTHER PECUNIARY OR OTHER LOSS
WHATSOEVER) ARISING OUT OF OR IN ANY WAY RELATED TO THE USE OF OR INABILITY TO
USE THE SOFTWARE, THE PROVISION OF OR FAILURE TO PROVIDE SUPPORT SERVICES, OR
OTHERWISE UNDER OR IN CONNECTION WITH ANY PROVISION OF THIS EULA, EVEN IN THE
EVENT OF THE FAULT, TORT (INCLUDING NEGLIGENCE), STRICT LIABILITY, BREACH OF CONTRACT
OR BREACH OF WARRANTY OF PST OR ANY SUPPLIER, AND EVEN IF PST OR ANY SUPPLIER HAS
BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

2.  

1. LIMITATION OF LIABILITY AND REMEDIES. Notwithstanding any damages that you might
incur for any reason whatsoever (including, without limitation, all damages referenced above and all
direct or general damages), the entire liability of PST and any of its suppliers under any provision
of this EULA and your exclusive remedy for all of the foregoing (except for any remedy of repair or
replacement elected by PST with respect to any breach of the Limited Warranty) shall be limited
to the greater of the amount actually paid by you for the Software. The foregoing limitations,
exclusions and disclaimers (including Sections 7, 8, and 9 above) shall apply to the maximum
extent permitted by applicable law, even if any remedy fails its essential purpose.

2.  

1. ENTIRE AGREEMENT. This EULA (including any addendum or amendment to this EULA which is
included with the Software) is the entire agreement between you and PST relating to the Software
and the support services (if any) and they supersede all prior or contemporaneous oral or written
communications, proposals and representations with respect to the Software or any other subject
matter covered by this EULA. To the extent the terms of any PST policies or programs for support
services conflict with the terms of this EULA, the terms of this EULA shall control.

 



 

 

Installing Components
EZ-Scan can be customized by adding custom reports, exports, imports, tools and plug-ins. You may
at some point have to install a component. The installation of a custom component is a 3 step process.
You must install the component itself (typically a .dll file), register the component, and then merge the
registry settings for that component. This is an advanced tutorial. This should only be attempted by and
administrator. PST will not be responsible for any damage to the operating system.
 
Installing the component
You must be logged in as an administrator to install any EZ-Scan components. You will be supplied
with a .dll file from PST that contains the custom component (ex. pstExpAch.dll is the ACH Export
component). Copy the file to your windows system directory. Typically this is 'C:\Windows\System32" for
32 bit OS and 'C:\Windows\SysWow64" for 64 bit OS.
 
Registering the component 32 Bit Example 64 Bit use SysWow64 Directory
EZ-Scan plug-ins, exports, reports and tools are all COM components. COM Components need to be
registered with Windows. To register you new component:
 
Click Start > Run and paste the following  text   C:\Windows\System32\regsvr32.exe C:\Windows
\System32\
 
Add the name of you new component to the end of this text. Using the ACH Export as an example the
text in the Run Dialog should be
C:\Windows\System32\regsvr32.exe C:\Windows\System32\pstExpAch.dll
 

 
Then click 'OK'. You will receive a confirmation dialog box if the registration was successful.
 



 

 

 
To Unregister a file, click Start > Run and paste the following text. ( using the ACH export as an example
again. Replace pstExpAch.dll with the component that  you will be registering)
C:\Windows\System32\regsvr32.exe /u C:\Windows\System32\pstExpAch.dll
 

 
Then click 'OK'. You will receive a confirmation dialog box if the file was unregistered successfully.
 

 
Merge registry settings for the component
Each component will have a corresponding .reg file. It should be located in the Setup folder in the
EZ-Scan application directory. By default that will be 'C:\EZ-Scan\Setup\' although this will vary if you
installed to a different directory.  The file will be named the same as the component, but with a .reg
extension.  For instance if you installed the file 'pstExpACH.dll' in the System32 directory, then  you
will need the file named pstExpACH.reg. It  may be have an underscore as the first character in some
instances ('_pstExpACH.dll). If the file is not located in the Setup folder contact PST to receive your .reg
file.
 
Double click on the corresponding .reg file and you will get the following prompt:



 

 

 

 
Click 'Yes' and you will get the following confirmation of the settings merge:
 

 
You component is now ready to use.



 

 

Supported Scanners
 
Digital Check Corporation Scanners

• DCC CheXpress™ CX30 (CX/30)
• DCC TellerScan™ 200 (TS/200)
• DCC TellerScan™ 210 (TS/210)
• DCC TellerScan™ 215 (TS/215)
• DCC TellerScan™ 220 (TS/220)
• DCC TellerScan™ 230-35 (TS/230-35)
• DCC TellerScan™ 230-65 (TS/230-65)
• DCC TellerScan™ 230-100 (TS/230-100)
• DCC TellerScan™ 240 All Models (TS/240)
• DCC TellerScan™ 300 (TS/300)
• DCC TellerScan™ 300EBS (TS/300EBS)
• DCC TellerScan™ 350 (TS/350)
• DCC TellerScan™ 350EBS (TS/350EBS)
• DCC TellerScan™ 400 (TS/400)
• DCC TellerScan™ 400E (TS/400E)
• DCC TellerScan™ 400ES (TS/400ES)
• DCC TellerScan™ 4080 (TS/4080)
• DCC TellerScan™ 4120 (TS/4120)
• BUIC 1000 (B/1000)
• BUIC 1500 (B/1500)

 
Fuji System Scanners

• FZ 1181
• FZ 3125
• FZ 5111
• FZ 5180
• FB Devices

Canon

• CanoScan LiDE 60

• CR-190i II

• CR-190i

• CR-180   
• CR-180II  
• CR-25    

• CR-50      

• CR-55    



 

 

• CR-80  
• DR-1210C
• DR-2010C         

• DR-2050C
• DR-2080C
• DR-2510C
• DR-2580C   
• DR-3010C              
• DR-3020
• DR-3060
• DR-3080C
• DR-3080CII
• DR-4010C
• DR-5010C
• DR-5020
• DR-5060F
• DR-5080C
• DR-6050C
• DR-6080
• DR-7080C
• DR-7090C
• DR-7550C
• DR-7580
• DR-9050C
• DR-9080C
• DR-X10C

 
  Panini

• Vision X series
• MyVision series

Fujitsu

• ScanPartner Series
• 3093G
• 3096G
• 3097G
• 3099
• 3097D
• 4097
• 4750C
• 4099
• 3091DC
• 3092DC
• 4120



 

 

• 4220
• 4340C
• 4530C
• 4860
• 5650C
• 5750C

 
Magtek

• Magtek Excella
• Magtek  Micr Image

 
Ricoh

• IS60/IS50
• IS410/420/450
• IS01
• IS330

 
 Panasonic

• 2025C
• 2026C
• 2045C
• 2046C
• 2055
• 2065
• 3065
• 6040
• 6045
• 6050
• 6055
• 855
• SS25
• SS50
• SS55

 
 Bell & Howell

• Copiscan 4040D

 
 
 



 

 

 



 

 

Add Custom Fields Dialog
When you click the 'Add' button  from the options screen 'Item Fields' page, the Add Field dialog box will
appear. This is where you will define your custom field(s) that will be added to the database.
 

Name
Name can be alphanumeric. Spaces and illegal filename characters are not allowed.
 
Caption
The caption can be different than the name of the field. It is the caption that the user will see when the
fields is displayed in EZ-Scan.
 
Data Type
You will need to specify what type of data that will be stored in the field. Your choices are:

• String (Text < 250 characters)
• Date
• Double (Amount)
• Integer (Whole Number)
• Boolean (Yes/No)
• Memo (Text > 250 characters)

       
Default Value
You can specify a default value for a field here. It will prefill the field where ever it is displayed if it a has
not been given a value.
 
Max Length
If the fields data type is String you will need to define a maximum length for any data that the field may
hold. For all other data types this property is disabled.
 
Field Type
If you are adding this field to appear on the Batch Properties screen, then choose Batch Field. If you are
adding  this field to each individual item, then choose Item Field. If you want the field to show up on the
Batch Properties screen and be saved with each item then choose Both.
 



 

 

Format
The format property will determine how the field will be formatted when displayed. The drop down list is
prefilled with many common formats. For instance to format an amount field to always display 2 zeros
you would use a format of '##.00'. You can enter any mask. It doesn't have to be in the drop down. If you
are not very familiar with formatting data, it would be advised to stick to the formats available in the drop
down.
 
Mask
The mask property will allow you to define an input mask for data entry. The drop down list is pre loaded
with some common masks. You cannot add your own mask and must choose from the masks in the list.
 
Required for Batch
If this check box is checked, the field will be required on the Batch Properties screen. The user will be
forced to fill the fields with valid data before scanning can begin.
 
Required for Item
If this checkbox is checked, this field will be required in the Verify program. When the user is verifying the
data this record must contain valid data. If is does not the user will have to key it in.
 
Require Decimal in Data Entry
If this is checked you will enter numeric data normally. If unchecked you can increase the speed of data
entry for numeric fields. The operator does not have to type the decimal when entering data. For instance
if the value to enter is 100.35, the operator enters 10035 and when focus leaves the field, the value
will be changed to 100.35. When this option is unchecked, the decimal key is mapped to "00" since the
decimal key is not needed for decimals. For instance, if the value to enter is 100.00, the operator would
type 100. this will fill the field with 10000. This will then be changed to 100.00 when focus leaves the field.
 
Editable
When checked, the field will be displayed in the Edit dialog box and the user will have the ability to edit
the data contained in this field.
 
Enable Range on Find
When checked, this will create a 'Field From' text box and a 'Field To' text box on the Find screen. ex See
the Process Date field in the image above. This will allow you to find data within a certain range.
 
ex. Amount From = 100 and Amount to = 200 will retrieve all items where the Amount field has a value
greater than or equal to 100 AND less than or equal to 200.
 

using the grid__Grid.htm#editing


 

 

Edit Fields
When you click the 'Edit' button  from the options screen 'Item Fields' page, the Edit Field dialog box will
appear. This is where you will define your the properties of the fields in the EZ-Scan database.
 

Name
Name can be alphanumeric. Spaces and illegal filename characters are not allowed. This is not an editable
field. The name for a field is created on the Add Field Screen.
 
Caption
The caption can be different than the name of the field. It is the caption that the user will see when the
fields is displayed in EZ-Scan. Simply type in the grid to change the caption.
 
Data Type
This is not an editable field. The data type for a field is set on the Add Field Screen.
You will need to specify what type of data that will be stored in the field. Your choices are:

• String (Text < 250 characters)
• Date



 

 

• Double (Amount)
• Integer (Whole Number)
• Boolean (Yes/No)
• Memo (Text > 250 characters)

       
Default Value
You can specify a default value for a field here. It will pre-fill the field where ever it is displayed if it a has
not been given a value.
 
Max Length
If the fields data type is String you will need to define a maximum length for any data that the field may
hold. For all other data types this property is disabled. This is not an editable field. The Max length for a
field is set on the Add Field Screen.
 
Field Type
If you are adding this field to appear on the Batch Properties screen, then choose Batch Field. If you are
adding  this field to each individual item, then choose Item Field. If you want the field to show up on the
Batch Properties screen and be saved with each item then choose Both.
 
Format
The format property will determine how the field will be formatted when displayed. The drop down list is
pre-filled with many common formats. For instance to format an amount field to always display 2 zeros you
would use a format of '##.00'. You can enter any mask. It doesn't have to be in the drop down. If you are
not very familiar with formatting data, it would be advised to stick to the formats available in the drop down.
 



 

 

 
Mask
The mask property will allow you to define an input mask for data entry. The drop down list is pre loaded
with some common masks. You cannot add your own mask and must choose from the masks in the list.
 



 

 

 
Required for Batch
If this check box is checked, the field will be required on the Batch Properties screen. The user will be
forced to fill the fields with valid data before scanning can begin.
 
Required for Item
If this checkbox is checked, this field will be required in the Verify program. When the user is verifying the
data this record must contain valid data. If is does not the user will have to key it in.
 
Require Decimal in Data Entry
If this is checked you will enter numeric data normally. If unchecked you can increase the speed of data
entry for numeric fields. The operator does not have to type the decimal when entering data. For instance
if the value to enter is 100.35, the operator enters 10035 and when focus leaves the field, the value will be
changed to 100.35. When this option is unchecked, the decimal key is mapped to "00" since the decimal
key is not needed for decimals. For instance, if the value to enter is 100.00, the operator would type 100.
this will fill the field with 10000. This will then be changed to 100.00 when focus leaves the field.
 
Editable



 

 

When checked, the field will be displayed in the Edit dialog box and the user will have the ability to edit the
data contained in this field.
 
Enable Range on Find
When checked, this will create a 'Field From' text box and a 'Field To' text box on the Find screen. ex See
the Process Date field in the image above. This will allow you to find data within a certain range.
 
ex. Amount From = 100 and Amount to = 200 will retrieve all items where the Amount field has a value
greater than or equal to 100 AND less than or equal to 200.
 
Lookup Fields
When Enable Lookup is checked, a lookup table is created in the database which can contain  a list of
values for that field. When the field is displayed anywhere in the program, (including the Find screen, Batch
Properties screen, Verify screen, Edit screen, etc) a drop down box will be used to contain the list of values
from the lookup table.
 
Allow Users to add new values
When checked the drop down box used to display the field will allow the user to enter a value that is not in
the list of values from the lookup table.
 
Add new values to lookup list
When checked any new value added by the user will be added to the lookup list when the record is saved.
This is not available if Display Friendly Values is checked.
 
Display Friendly Values
In the Lookup table there are 2 fields created. Item Data and Display. The Item Data field contains the data
that will be saved in the database when a record is saved. The Display field is data that will be displayed to
the user to make data entry easier.
 
For example, if you have an account field with the values 11111,22222, and 33333. You can add the
account name to each one of these fields in the display field of the lookup table and that is what will be
displayed to the user for data entry. If the user selects 'Acme Saving' from the list, the corresponding Item
Data value will be saved in the database (11111). The edit screen is shown with Friendly Values displayed
for the Account lookup field below.
 

using the grid__Grid.htm#editing
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Edit Lookup Table
This will allow you to enter the list of values that will be used for lookup fields. Just type the data into the
grid.
 
Remember: The item data field is the field that will be saved to the database. The display field will simply
be used for display to the user. If Friendly Values are not being used leave the Display column blank.
 



 

 

 
Show Options
The show options will define where the custom field will be displayed in EZ-Scan. Check the checkbox for
each place that you want the field displayed. Your choices are:

• Show on Batch Screen
• Show on Verify Screen
• Show in Find
• Show in Grid

 
 



 

 

 



 

 

Customer Support
 
 
 

For hardware or software support please call 1-800-778-2621
between the hour of 9:00am to 5:00pm EST.
 
Precision Software Technologies, Inc.
23110 State Road 54   #326
Lutz, FL 33549
 
  
Phone:     (813) 996-5500
Fax:          (813) 996-5600
 
Email:  support@pstezscan.com
 
 

 

 

 

 

 

 



 

 

Downloads
 
The newest PST Software can be downloaded at http://www.pstinc.net/pub
 
You can get the latest applications, drivers, tools, etc. from there.
 

 
Using the filter by drop down you can show just :

• Applications
• Drivers
• Misc
• Plug-ins
• Utilities
• All

 
Most of the applications are password protected. Contact PST to receive the password.
The EZ-Scan viewer is not password protected.
 

http://www.pstinc.net/pub


 

 

 



 

 

View Menu
 
The View menu allows you to customize the look of EZ-Scan to fit your needs. With it you can show or hide
the following visual elements.

• Toolbar
• Thumbnails
• Batch Properties
• Item Properties
• Button Controls
• Back Image
• Status Bar
• Vertical Splitter

 
Selecting an item on the menu will check it and make it visible. Selecting a checked item will uncheck and
hide that visual element.
 



 

 

 
 
View Examples
Here are some different examples of the visual interface with different elements visible.
 
Grid with Thumbnails.
 

 
Grid, Batch Properties, Item Properties, Button Controls, and Toolbar visible.
 



 

 

 
 
Here is the main screen with just the button controls and grid visible. The data in the Batch and Item
properties fields can still be seen in the grid.
 



 

 

 
 
To maximize viewing area, you can eliminate all of the side controls to dedicate more space to the image
and grid data.
 



 

 

 
 
By pressing Ctlr + G, Ctlr + B or from the View menu, you can toggle between the back image and the grid.
 



 

 

 
 
If you would like to see both the front and back image while viewing the grid, you can choose to turn on the
Vertical Splitter.
 



 

 

 
 
You can maximize the screen area for large documents, by reducing the size of the grid along with
removing the button controls panel.
 



 

 

 
Splitters
As you can see from the different screen captures, the grid height can be adjusted. Place your cursor over
the line dividing the grid from the image your cursor will turn to a double arrow. At this point you can drag
the splitter up or down to adjust the height of the grid. You can also grab and drag the vertical splitter.
 
Alternate View
If you have documents that vary in size you may want to set up an Alternate View. This will allow you to
view large documents with the image window maximized, the grid sized down to only a few rows and all
the controls on the right side hidden. You may also want to view your smaller documents or checks with the
screen real estate equally divided between the image and the grid with the buttons controls on the right.
 
First set the current view to fit your first document type. Then click View>Alternate View ,or click the F7 key.
Adjust the layout to fit your second document type. Now by clicking View>Alternate View, or the F7 key,
EZ-Scan will toggle between both views.
 
Data Verification View
Any visual settings that you set up during the Data Verification process will be saved so that you can have
a different view while verifying. You may want to see the thumbnails while verifying, but not in the main



 

 

window for instance the splitter above the verify fields has been moved all the way to the top of the screen
eliminating the main image and thumbnails have been turned on and set to '2'. This allows you to view 2
images at  a time while verifying. This can be useful for remittance processing when you need to get data
from one document to use on another document in the transaction.
 

 



 

 

 



 

 

Data Verification
 
When scanning, the MICR reader reads and parses most of the MICR lines accurately, but some data
might be misread. This data will need to be keyed in by a user. EZ-Scan provides a fast and easy interface
to correct and fill in missing field data.
 
First you will need to get the data into the grid that you would like to verify. This can be done by scanning
items, or by doing a search for the items. For instance, you could do a search for all items that have a
Process Date of today, or you could run the Verify program right after scanning a batch while the items
scanned are still in the grid.
 
You can get to the verify screen 3 ways.

1. Go to Tools>Verify from the main menu
2. Hit the F9 key
3. Click the Verify button on the toolbar
4.  

 
The Verifier will go through the data in the grid, using the criteria set up in the options screen. It will
check for required fields, and fields to display in the Verifier. From the option screen you can set the field
properties for each field, which include 'Show on Verify' and 'Required for Item'. If the field is set to 'Show



 

 

on Verify' it will be visible on the screen above. If it is set to 'Required for Item' the Verifier will know to stop
on that field, for you to enter the data if it is missing. It will loop through the records that were in the grid
and only stop on the ones with data missing from the required fields. When it locates a record with missing
data, it will then highlight and set focus to the first field with missing required data from that record.
 
Using the 'Enter' key, you can speed through the data entry. The Verifier will stop on a field, the user
keys in the data and hits the 'Enter' key. The data is saved, and the next missing field in that record is
highlighted, if there is any more required fields missing in that record. If that record is complete, the system
will save the data and continue searching until it finds the next record with missing required data and then
repeat the process. This process should be very easy to use for casual user or an experienced 10 key
operator.
 
You can edit any of the fields displayed in the Verifier, not just the required ones. The system will only
highlight the required ones. You can also move through the records with the record navigation buttons on
the toolbar.
 
When all required data is captured, the Verifier will inform you that all data has been verified and ask you if
you would like to close the Verify screen. Click 'Yes' and you will return to the main EZ-Scan screen.
 
Shortcuts
The '+' key can be used to fill a field with the last value entered for that field. This will speed up data entry
when you have multiple items with the same value.
 
The '-' key can be used to clear the value in a field
 
Numeric fields have a 'require decimal in data entry' property. Setting this property to false will allow
the user to enter the data without the decimal. The decimal will be added before the item is saved
automatically. For instance, if the value is '100.35', the user would simply type '10035' and hit enter. A
value of '100.35' will be saved in the database. When the property is set to false the decimal key will be
mapped to '00' since the decimal is not needed. Therefore, if the value is '100.00', the user would type in
the value '100. ' and hit enter. A value of 100.00 would be saved in the database. Remember if you type
'100' without the '.', it will be saved as '1.00'. This setting can be changed in the Add/Edit field dialog.
 
Lookup Fields
The Verifier supports lookup fields. In the Add/Edit field dialog you can enable lookup values for a field.
The user will be presented with a drop down box for a field with lookup enabled. The drop down list will be
filled with values from the lookup table for that field. The user can be restricted to selecting only values in
the list or can add new values depending on the settings for that field.
 



 

 

 



 

 

 
MS SQL Server Setup Guide

New Installation

You will need the following script files to create the EZ-Scan database.
• EZScan_DB.sql
• EZScan_IDX.sql
• EZScan_CheckFields_IDX.sql (optional)
• EZScan_ItemsLookup.sql (optional)
These files will be installed by the EZ-Scan installation to the ‘Setup’ subdirectory This will be C:\EZ-Scan\Setup if
the default location for the installation is used.
 
Create EZ-Scan SQL Server Database

Open SQL Server Management Studio
Create a new database by right clicking on 'Databases' in the left pane.
Name it EZScan or another more appropriate name.
 
Create tables in the EZ-Scan SQL Server database

IMPORTANT: Choose the new EZScan database from the dropdown on the toolbar
Go to File>Open and select EZScan_DB.sql
Click the execute button on the toolbar (F5)
 
Create Indexes in EZ-Scan SQL Server database

IMPORTANT: Choose the EZScan database from the dropdown on the toolbar
Go to File>Open and select EZScan_IDX.sql
Click the execute button on the toolbar
You can optionally add indexes to the main check fields by repeating this process with
EZScan_CheckFields_IDX.sql
The EZ_Scan_CheckFields_IDX.sql can be modified to add indexes for other fields as needed.
 
Upgrading from an existing Access database

If you are upgrading from an Access database the Access upsizing wizard.
Open your existing database in Access and on the Database Tools tab select SQL Server to start the upsizing wizard.
Follow all of the instructions and it will create the new SQL Server database and import the data from your existing
database.
 



 

 

Opening the SQL Server database with EZ-Scan

EZScan uses .UDL files to attach to SQL databases
To create a UDL file simply create a new text file on your file server by right clicking and choosing New>Text
Document
Name the file EZScan.udl and an appropriate name with a  .udl extension
Double Click the EZScan.udl file and a Data Link Properties dialog box will appear
On the Provider tab select Microsoft OLE DB Provider for SQL Server
On the Connection tab select or type in your SQL Server name in the Combo box at the top
Select Use Windows NT Integrated Security. If you choose a specific username and password, it will be visible in
your UDL file which is simply a text file and not encrypted

Select the EZScan database from the database list
Click the 'Test Connection' button to test
From EZScan go to File Open Database and select the EZScan.udl file that you just created
 
 
 
 
 
 
 
 
 
 
 
 



 

 

New Database Wizard
 
To create new database in EZ-Scan go to File>New Database from the main menu. This will start the New Database Wizard to walk you
through the creation of a new database.
 
Database location
 

 
 
You can choose a database  template when creating a new database. By default a 'Checks' database will be created, but you can  choose
templates for a specific need from the dropdown. Some choices are:
 
Checks            Choose this if you will be scanning primarily checks
ACHExport     Choose this if you will be using the ACH export
Documents     Choose this if you will be scanning full page documents
Ivory                  Choose this if you will be importing data from an Ivory system
IvoryProVer2   Choose this if you will be importing data from an Ivory 2.0 system into EZ-Scan Pro
FPS (POD)   Choose this if to run the FPS proof software with EZ-Scan

 
A custom template can be created for you if you have special needs. Contact PST if you do not see the template that you would like to use.
 
After choosing the template the location for the new database click 'Next'
 
Image Storage Location
 



 

 

 
Now tell EZ-Scan where you would like to store your images.
 
You will have this choice in all editions of EZ-Scan except 'Lite'. With 'Lite' you can only store images in the database.
 
For all other editions of EZ-Scan you have 2 choices.

• Store images in the database
• Store images in files
•  

Images in database
Choose this option if you do not need long term storage. The default Microsoft Access database will hold approximately 150,000 to 175,000
images and data for those images. It is a convenient option if you only need to store your data and images for a short period of time. You
can purge data and images using the 'Purge Data' feature under the 'Tools' menu. If you are using an Remit database such as Microsoft
SQL Server, MySQL or Oracle then you are only limited to your available disk space.
 
Images in files
Choose this option to store the images in separate images files. This is the default setting in all but the Lite Edition of EZ-Scan.
Click the 'Browse' button to select the location that you would like to use. By default it will save the images in 'C:\EZ-Scan\Images\'.  You can
change this setting to store the images on a network share.
 
Scanner Selection
 



 

 

 
Choose the scanner that you will be using from the list of available scanners in the dropdown list. If you are unsure of which device to
choose, the Scanner Drivers page will give you more details.  If the scanner is already attached and the drivers have been installed, you
can also click the 'Configure' button to set specific settings for your scanner.  See the Installing Hardware section of the help file for more
information on installing your scanner.
 
Required Fields
 

 
Here you can choose the fields that you would like to display in the 'Data Verification' program. Just check  the fields that you require.
 
Export Format
 



 

 

 
EZ-Scan comes with different export formats built in. You can choose the one to set as your default export here. The other export formats
will still be available from the file menu if needed. The following export formats are available with EZ-Scan.

• EZ-Scan database export
• Text export
• SER Synergy Check export
• SER Synergy Doc export
• Full Text export
• EZ-Scan Image Export
• Check 21 Export
• ACH Export
• BAI Export
• Reliafund Export
• XML Export
• PDF Export
• QIF Export (Quicken or Money)
• OFX Export (Money)

 
EZ-Scan can have custom exports created to fit your particular needs if the included exports don't meet your needs. Contact PST for details.
 
Finish
 



 

 

 
Just click 'Finish' to open the new database in EZ-Scan or click the 'Back' button to review your choices. You can click 'Finish' at any time
during the New Database Wizard to open the new database in EZ-Scan.
 



 

 

 



 

 

Emailing Images
 
EZ-Scan can attach images to an email very easily. Simply select the items in the grid that you would like
to email and click File>Send Email from the main menu or click the Email icon on the toolbar.
 
The dialog box  similiar to the Print dialog box will be presented.
 
The following options are available:
 

• Attach the images as TIFF/JPEG or PDF files.
• The page size can be selected from the drop down.
• The images can be formatted into columns and rows.
• The items email can be selected as follows:

• Entire grid
• Currently selected rows.
• Currently selected image.

• You have the choice to print back images, captions, and frames.

 

 
 
A new email will be created with your default email editor and the selected images will be attached.
 



 

 

 
Simply fill in the recipients address and message. Your email is ready to send.



 

 

 



 

 

PST ACH Export
 
Getting Started
The ACH Export will need to use the ACHExport database template. When starting EZ-Scan for the first
time or if creating a new database you will need to select ACHExport from the template dropdown.
 
NOTE: This is very important. You will not be able to use the ACH Export if you did not use the ACH Export
template when creating your database.
 

 
Configure the Export
 
The PST ACH Export will need to be configured before you can use it for the first time. To configure this
export go to Tools>Options and click on Export in the right tree of the options dialog. Then select the PST
ACH Export from the drop down list and click the configure button.
 



 

 

 
If you do not have  the PST ACH Export listed in the list of available exports then you will need to add it by
installing  its registry file to make it available. See Installing components for details.
 
 
General Tab:
 



 

 

 
 
Export history database:
This database contains the export history data. It will be used to track duplicate items in the ACH export.
By default it will be located at C:\EZ-Scan\EZACH.mdb This file can be located on a server so that multiple
workstations can share the same history data.
 
Export Path and Export File (optional):
The path and filename can be saved with each profile. If a value is not specified, then the values from the
export page on the options screen will be used.
 
Include line breaks:
This will insert a line break character after each line in the file. This is checked by default and typically does
not need to be changed.
 
 
File Header Options:
Origin Number:



 

 

The route code or customer number assigned to the sender of the file.
 
Origin Name:
The name of the sender of the file.
 
Destination Number:
The route code or numeric identifier of the receiver of the file.
 
Destination Name:
The name of the receiving institution.
 
Reference Code (optional):
A code defined by the receiver of the file. Not required.
 
Priority Code:
'01' by default.
 
File ID Modifier:
Auto by default. In Auto the file ID modifier will be incremented with each file created on the same day. The
valid values are 0-9 A-Z
 
 
Batch Header Options:
Service class code:
'225' by default.
 
Company Name:
The name of the sender of the file.
 
Discretionary  Data:
'Check Data' by default. Used in the batch header to describe contents of batch.
 
Company  ID:
An account number or identifier of the sender of the file.
 
Originator  Status Code:
'1' by default.
 
Origin DFI ID:
The route code or customer number assigned to the sender of the file.
 
 
Default Record Options:
Terminal City  and State (optional):
The location of the sender of the file.
 
Min check field len:
'6' by default. Check numbers will be padded with '0's to the  number of characters specified.
 



 

 

Default Entry Code:
ACH records can be created in multiple formats defined by the entry class code value. If you will be
transmitting all records in the same format then this value will be used to define the format used for each
detail record.
 
When you scan the entry class code can be entered for the items in the batch. This will allow you to create
ACH records in different formats for each batch.
 

 
A default value for the entry class code can be defined for the batch screen, by going to Options>Batch
Fields and clicking Edit. See Batch Field Options Settings  for more details. The Entry class code field can
also be defined as an item field and keyed in the Verify program to allow for unique ACH formats on each
item in a batch.
 
Default Transaction Code:
The transaction code field is an item field which has the same flexibility as the Entry Class code. A default
value can be defined on the option screen that will be used for any item without a value specified. The
Transaction Code field can be define as a Batch Field and added to the Batch prompt screen as seen
above to define transaction codes at a batch level, or it can be defined as an item field where data can be
keyed in on an item by item basis in the Verify program.  See Batch Field Options Settings or Item Field
Options Settings for more details.
 
 
Includes/Excludes Tab:
 



 

 

Doc Types:
You can define which document types are included or excluded from the file.

• Select Include or Exclude from the doc types drop down.
• Select the doc types from the list box.
• Select multiple doc types by holding the ctrl key while clicking.

 
EPC:
You can include or exclude by the EPC value on the checks. The EPC fields is a single character field to
the left of the Route code in the MICR line. This field is only on IRD's (Image replacement documents).

• Select Include or Exclude from the EPC drop down.
• Select the EPC values  from the list box.
• Select multiple values by holding the ctrl key while clicking.

 
Route Codes:



 

 

You can include or exclude by the Route Code value on the checks. This feature can be used to include or
exclude On Us or transit checks to create files with only On Us checks or only Transit Checks.

• Select Include or Exclude from the Route Code drop down.
• Add the Route Code (s) one per line  to the grid

 
 
Advanced Tab:
 

 
Implement local Holds (POD entry class code only):
The POD entry class code only applies to FPS POD customers.  
The POD detail record contains a Local Hold field.
Valid values are :

• No Hold = 00
• Local Hold = 01



 

 

• Non Local Hold = 02
•  

If 'Implement Non Local holds' is checked then items in the file with a route code in the grid will be give a
value of 01. Items with a non local route code will be given a value of 02.
 
If 'Implement Non Local holds' is not checked then all items will be give a value of 00.
 
 
Settings Profiles (optional):
If you need to create ACH files with different settings you can save each set of settings in a profile which
can be selected on export.
click the Add button to create a profile. You can add as many profiles as needed.
 

 
Exporting Data
The PST ACH Export will export data using the Process Date, or you can export items in the grid that you
have just scanned or retrieved using the find feature.
 
Make sure that you have verified all the data for the items that you will be exporting.
 
You can get to the ACH Export a few different ways.

• File>Export>PST ACH Export.

 
If you have the PST ACH Export set as your default export then you can also

• Click the Export Button on the toolbar.
• Click the Export Button on the lower right of the screen.

 
You will see the following confirmation screen. Make sure all the data is correct and click 'OK' to start the
export. You can click the button next to the Settlement Date to automatically fill in today's date as a Julian
Date. Click the button next to the Export Path  to browse for the directory to export the file to.  The filename
will be automatically generated, but you can change it to whatever name you like. You can also click the
'Configure' button to double check the Export properties before exporting.
 



 

 

 
If the export file already exists you will be warned that it will be overwritten if you continue.
 

 
Click 'No' to return to the Confirmation dialog and change the filename, or Click 'Yes' to continue and
overwrite the existing file.
 
If you have already exported files for this same Process Date you will be alerted  that files have already
been exported for this date. You can choose to re-export those today's items or cancel.
 

 
 



 

 

If you choose to re-export, keep in mind that duplicate items may exist in the previous file. It is
recommended to just do one export for each day. If there are duplicates within the export the user will be
prompted with the duplicate item screen.
 

 
You have the choice to export this item again or to cancel and fix the items in question.
 
When the export is complete you get a confirmation message.
 



 

 

PST Check 21 Export
 
Configure the Export
• Click on Tools>Options >Export.
• Verify that the EZ-Scan Check 21 Export is selected in the dropdown.
• Click Configure.
• If you are prompted to create the ACH database file, click ‘Yes’ to create it.
 

• Click yes to create ACH database file.
 
• Fill in all settings on the main screen. If you are unsure of the settings needed, the destination institution
should be able to provide you with all of the necessary information.  
 



 

 

 
Export history database: This database will be used to store the history records for items exported with
the Check 21 export. By default it is located at C:\EZ-Scan\EZAch.mdb.
 
Ignore duplicates in export: The history database is checked on each item exported for duplicates. This
check will not be done if checked.
 
File Header Information (01 record)
Origin Number: A number that identifies the institution that creates the Cash Letter.
File ID: A code that identifies the file uniquely per day, assigned by the institution that creates the file.
(Default is "1").
Origin Name: The short name that identifies the institution that sends the file.
Dest Number: A number that identifies the institution that receives and processes the cash letter or the
bundle.
Dest Name: The short name that identifies the institution that receives the file.
Country Code:  Value is US.
User Field: User data in field 13 of the File Header record.
 



 

 

 
Cash Letter Information (10 record)
Origin Number:A number that identifies the origin ECE institution in the cash letter header and bundle
header.
Origin Name: The short name that identifies the origin ECE  institution within the cash letter control record.
Record type: A code that indicates the presence of records or the type of records contained in the cash
letter.
Fed work type: A code that specifies the Federal Reserve work type.
Collection type: A code that identifies the type of cash letter. 01=Forward 03=Return.
Documentation: A code that indicates the type of documentation that supports all check records in the
cash letter. This code indicates whether or not the items contained in the cash letter are the same type.
Contact: A contact at the institution that creates the cash letter.  Required, unless omitted under clearing
arrangements.
Phone: The phone number of the contact at the institution that creates the cash letter. Required, unless
omitted under clearing arrangements.
Cash letter ID: A code that identifies the cash letter, assigned by the institution that creates the cash letter.
User field: User data in Field 14 of the Cash Letter Header record
 
 
Detail Information (25 record)
Archive type: A code that indicates the type of archive that supports this Check Detail Record. Access
method, availability and timeframes shall be defined by clearing arrangements.
 
Endorsement:

• BOFD endorsement - the originator is the Bank of First Deposit
• Subsequent Endorsement - the originator is neither the payor or the BOFD
• Payor Endorsement - the originator is the Payor institution.

BOFD type: A code that indicates whether the ECE institution indicated on the Bundle Header Record
(Type 20) is the Bank of First Deposit (BOFD).
Return type: A code that indicates whether the institution that creates the Check Detail Record will or will
not support electronic return processing.
MICR Indicator: A code that indicates whether any character in the MICR line is unreadable, or, the On-Us
field is missing. Most users should  select 'Auto'
Correction Indicator: An indicator to identify whether and how the MICR line was repaired, for fields other
than Payor Bank Routing. Most users should  select 'Auto'
 
 
Addendum A BOFD Information (26 record)
BOFD Number: A number that identifies the Routing Number of the Bank of First Deposit.
Deposit Acct: A number that identifies the depository account at the Bank of First Deposit.
Deposit Branch: A code that identifies the branch at the Bank of First Deposoit.
User Field: User data in Field 12 of the Addendum A record.
 
 
Bundle Information (20 record)
Return Number:A Routing Number specified by the Institution that creates the bundle, indicating the
location to which returns, final return notifications and preliminary return notifications should be sent.



 

 

Cycle: A code assigned by the institution that creates the bundle. Denotes the cycle under which the
bundle is created.
User Field:User data in Field 11 of the Bundle Header record.
 
 
Create Credit Record (61 or 25 record)
Credit records are required by some destination institutions. Credit records are not part of the Check 21
specification and vary by institution. EZ-Scan supports all of the major institutional variations and continues
to implement custom requirements as needed.
 
The credit record is the digital equivalent of a deposit slip.
 
At this time several variations of the credit record are supported by EZ-Scan

• Bank of America - 61 record
• Wachovia - 61 record
• Wells Fargo - 61 record
• Jack Henry - 25 record

 



 

 

 
Select the appropriate credit record type from the drop down list. When doing so you will be prompted to
add or remove values specific to that credit record type. Default values will be loaded where possible.  The
destination institution should be able to provide you with the information to fill out this section properly.
 
 
Deposit Account and Deposit Route: You can enter a value here for the deposit account and route. If
you need to create records with different deposit account and route values, you can click the ellipsis next
to the account or route to add corresponding batch fields to the database that can be used to enter deposit
account and deposit route values on a batch level basis.
 



 

 

 

 
When you scan you will have the deposit account field added to the Batch Screen, so that you can define a
deposit account for the items in the batch. If you leave the deposit account blank on the batch screen, then
it will use the value from the options screen.
 

 
Tran Code: Tran code from the credit ticket.
Aux On Us: The Aux On-us information from the credit ticket.
Source of Work: Source of Work (not Required)
Account Type: Account Type (not Required)
Documentation Type: Documentation Type (Default Value "G")
Work Type: Work Type (not Required)
 
Include images with Credit record: Some institutions will require deposit ticket images be included with
the credit record.



 

 

Front and Back Image:  Browse to select the  front and back image used for the credit ticket. You can
scan a deposit ticket, or the destination institution may supply you with the appropriate images.
 
 
• Click the Advanced Tab
 

 
 
Include or Exclude items
 
• Document type: You can choose to include or exclude documents by their document type. Select include
or exclude from the drop down list and then select the document types to include or exclude in the list.  Ctrl
+ click or Shift + click to select multiple types.
• Route: You can choose to include or exclude documents by their Route code value. This will allow you to
create a file of OnUs or Transit items.. Select include or exclude from the drop down list and then enter the
Route codes one per line, in the grid.
• EPC: You can choose to include or exclude documents by their EPC code value.  Select include or
exclude from the drop down list and then select the EPC values to include or exclude in the list.  Ctrl + click
or Shift + click to select multiple types.



 

 

 
Wells Fargo Format: If you need to create a file in Wells Fargo Format check this box. It will create records
without length indicators as required by Wells Fargo.
Validate Route Code check digit: This will validate the check digit on the route code of each item as it is
exported. The user will be alerted if a route code does not have a valid check digit and the export will be
cancelled.
 
Export Path and Export File: The export path and filename can be specified here and will override values
from the options screen. This values are optional.
 
Profiles: Profiles give you the ability to have different 'Sets' of settings. You may need one set of settings
for ONUS items and another set of settings for Transit items. You may also need different settings for
different customers. To add a profile click the 'Add' button in the profile frame.
 

Type in a descriptive name and click 'OK'
 
You can add as many profiles as you need. You will have the choice to select the profile to create on the
confirmation dialog box when you create your export file.
 
Test Mode: Check this box to create a file in Test mode so that it will not be processed during the testing
phase.
 
Enter the appropriate information and click 'OK' to save your settings.
 
 
Exporting Data
 
Make sure that you have verified all the data for the items that you will be exporting.
 
You can get to the PST Check 21 Export a few different ways.

• File>Export>PST Check 21 Export

 
If you have the PST Check 21 Export set as your default export then you can also

• Click the Export Button on the toolbar
• Click the Export Button on the lower right of the screen.

 
You will see the following confirmation screen. Make sure all the data is correct and click 'OK' to start the
export.
 



 

 

 
 
You can export by process date, scan date or you can export  items in the grid. You can retrieve items using
a find using any of the criteria on the find screen. Check the 'Use data in the grid for export' check box to
export the items in the grid.
If the export file already exists you will be warned that it will be overwritten if you continue.
 

 
Click 'No' to return to the Confirmation dialog and change the filename, or Click 'Yes' to continue and
overwrite the existing file.
 
If you have already exported files for this same Process Date you will be alerted  that files have already
been exported for this date. You can choose to re-export those today's items or cancel.
 



 

 

 
 
If you choose to re-export, keep in mind that duplicate items may exist in the previous file. It is
recommended to just do one export for each day. If there are duplicates within the export the user will be
prompted with the duplicate item screen.
 

 
You have the choice to export this item again or to cancel and fix the items in question.
 
When the export is complete you get a confirmation message.
 



 

 

 
You have the option of looking at the log file when complete. Click 'Yes' to view the log file.
You will be presented with the details and any possible errors that occurred during the export.
Log file created on 2010-04-12 at 15:59:02.
 
(20100412 15:59:02)  
(20100412 15:59:02) **********************************************************************************************
(20100412 15:59:02) CHECK 21 EXPORT BEGIN
(20100412 15:59:02) **********************************************************************************************
(20100412 15:59:02) Filename: c:\EZ-Scan\Exports\test.c21
(20100412 15:59:02) Profile: Test Profile
(20100412 15:59:02) Business Bundle date: 4/12/2010
(20100412 15:59:02) Business Cash Letter date: 4/12/2010
(20100412 15:59:02) ACH Database: c:\EZ-Scan\EZACH.mdb
(20100412 15:59:05) Bundle ID: 0000000001
(20100412 15:59:08) Bundle Item Count: 5
(20100412 15:59:08) Bundle Image Count: 10
(20100412 15:59:08) Bundle Total: $2,468.37
(20100412 15:59:08) Bundle ID: 0000000002
(20100412 15:59:09) Bundle Item Count: 5
(20100412 15:59:09) Bundle Image Count: 10
(20100412 15:59:09) Bundle Total: $544.23
(20100412 15:59:09) Bundle ID: 0000000003
(20100412 15:59:09) Bundle Item Count: 5
(20100412 15:59:09) Bundle Image Count: 10
(20100412 15:59:09) Bundle Total: $328.32
(20100412 15:59:09) Bundle ID: 0000000004
(20100412 15:59:11) Bundle Item Count: 5
(20100412 15:59:11) Bundle Image Count: 10
(20100412 15:59:11) Bundle Total: $1,957.82
(20100412 15:59:11) Bundle ID: 0000000005
(20100412 15:59:15) Bundle Item Count: 5
(20100412 15:59:15) Bundle Image Count: 10
(20100412 15:59:15) Bundle Total: $2,468.37
(20100412 15:59:15) Bundle ID: 0000000006
(20100412 15:59:15) Bundle Item Count: 5



 

 

(20100412 15:59:15) Bundle Image Count: 10
(20100412 15:59:15) Bundle Total: $544.23
(20100412 15:59:15) Bundle ID: 0000000007
(20100412 15:59:16) Bundle Item Count: 5
(20100412 15:59:16) Bundle Image Count: 10
(20100412 15:59:16) Bundle Total: $328.32
(20100412 15:59:16) Bundle ID: 0000000008
(20100412 15:59:17) Bundle Item Count: 5
(20100412 15:59:17) Bundle Image Count: 10
(20100412 15:59:17) Bundle Total: $1,957.82
(20100412 15:59:17) Bundle ID: 0000000009
(20100412 15:59:19) Bundle Item Count: 5
(20100412 15:59:19) Bundle Image Count: 10
(20100412 15:59:19) Bundle Total: $2,468.37
(20100412 15:59:19) Bundle ID: 0000000011
(20100412 15:59:20) Bundle Item Count: 5
(20100412 15:59:20) Bundle Image Count: 10
(20100412 15:59:20) Bundle Total: $544.23
(20100412 15:59:20) Bundle ID: test
(20100412 15:59:24) Bundle Item Count: 15
(20100412 15:59:24) Bundle Image Count: 30
(20100412 15:59:24) Bundle Total: $4,970.42
(20100412 15:59:24) File Item Count: 65
(20100412 15:59:24) File Total: $18,580.50
(20100412 15:59:24) 65 items exported.
(20100412 15:59:24) **********************************************************************************************
(20100412 15:59:24) CHECK 21 EXPORT COMPLETE
(20100412 15:59:24) **********************************************************************************************



 

 

Export Data
 
To export data and images in EZ-Scan you must first get the data that you want to export into the grid.
You can do this by doing a search for the data that you want to export, or you can export the data in the
grid after scanning.
 
Once you have the data in the grid that you would like to export, you can run the export by:

• Click the 'Export' button on the right side of the screen.
• Click the 'Export' icon on the toolbar.
• Click File>Export> then click the export that you would like to use from the menu list of

available exports.

 
Clicking the 'Export' button on the right side of the screen, or the one on the toolbar will run the default
export set up in the Options screen Export tab. By using the File menu, you can choose from all available
exports.
 

 
The data will be verified before the export screen is displayed. If there is any data that needs to be
corrected, the user will be prompted that 'x' number of records have unverified data, and will be asked if
the user would like to run the Verifier at this time. If the user chooses to verify the data, the Verifier will
open to allow the data to be corrected. After the data is verified, the user will need to start the export
again.
 
At this point the export settings screen will be displayed. It will vary depending on the export chosen.
The exports built in to EZ-Scan are:

• EZ-Scan database export
• EZ-Scan text export
• SER Synergy Check export
• SER Synergy Doc export
• Full Text export
• EZ-Scan Image Export
• EZ-Scan Check 21 Export
• PST ACH Export
• PST BAI Export
• Reliafund Export
• XML Export



 

 

• ATE Export
• CSP Export
• KLIK Export
• OFX Export
• QIF Export
• Quickive Export
• Reliafund Export
• Syngence Export

 
 Click on each link above to learn more about each export.
 
The Image Export is very useful for exporting images from EZ-Scan. The images can be exported as one
tiff file containing a page for each image, or separate files for each item.
 
The settings screen typically has the path and export file name used for the export, along with other
custom settings if they apply.
 
Click the 'OK' button to run the export.
 
The exported data will be saved to the location specified in the Path and Filename settings from the
settings screen.
 
 
 



 

 

EZ-Scan Database Export
 
This export will export data in an EZ-Scan access database format which can be opened by EZ-Scan or
EZ-Scan Viewer software. It will contain data and images for each item exported.
 
Retrieve the items that you would like to export by doing a Find. For instance do a find for all items with a
process date of the current day, to export the days work.
 
Once you have the items in the grid that you would like to export then, Select  File -> Export-> Export EZ-
Scan Database from the menu.
 
Before exporting EZ-Scan will check the items currently in the grid to see if any of the items need to be
verified. If any of the items do need to be verified, you will be given the opportunity to verify them before
exporting. You will be prompted with this dialog box.
 

 
If you choose 'Yes', you will be taken to the Verify screen to correct the data. You will then automatically
returned to the export when verification is done. If you click 'No', you will proceed to the export.
 
This export will export the data  in the grid  in an EZ-Scan Database format with the images stored in the
database. Browse for the Export path using the 'Browse' button to the left of the 'Export Path' text box.
Enter a descriptive name for the file to be exported and click 'OK' to start the export.
 

  
 
This export can be used to archive data and images. Typically, you would do a search by date range. For
example from 01/01/2002 to 01/31/2002.  You can take that file and burn it to a cd. You can then delete
the data and images in the main database using the Purge Data program.
 
When you need to retrieve data from this CD simply open it using the Open Database command from the
File menu on the main screen of EZ-Scan.
 



 

 

TIP: Always make sure to reopen the main database before trying to scan. You won't be  able to scan to a
database on and CD, but if you are opening it from a hard drive, you could.  Make sure that you have the
correct database open before you scan new data.
 
 



 

 

EZ-Scan Image Export
 
The EZ-Scan Image Export can be used to export images from EZ-Scan.  The images can be exported
as one tiff file containing a page for each image, or separate files for each item.
 
To use the Image Export, choose File>Export>EZ-Scan Image Export.
 
Before exporting EZ-Scan will check the items currently in the grid to see if any of the items need to be
verified. If any of the items do need to be verified, you will be given the opportunity to verify them before
exporting. You will be prompted with this dialog box.
 

 
If you choose 'Yes', you will be taken to the Verify screen to correct the data. You will then automatically
returned to the export when verification is done. If you click 'No', you will proceed to the export.
 
 
You will be presented with the following dialog box.
 

 
On this dialog box you can select the directory that the image export will create the image file or files in.
You can use the browse button on the right to select the directory.
 
You can export your images in 2 ways:
 
A separate file for each item exported, named with the following naming convention:
Company.Date.Batch.item.tif ex.  PST.20040101.Batch1.000021.tif
 
All items from each batch added to one file, named with the following naming convention:
Company.Date.Batch.tif ex PST.20040101.Batch1.tif
 



 

 

Note: If using the image export, it is recommended to scan images in .TIF or .TIF multi formats. If you
scan in .JPEG or .JPEG Multi, a .TIF encapsulated .JPEG image will be exported. This format image may
not be viewable in stardard image viewers. However, it can be viewed by the PST Image Viewer. Image
format is set by clicking Tools>Scanner Setup from the main EZ-Scan menu.



 

 

EZ-Scan Text Export
 
This export will export the data  in the grid  in an ASCII text file which can be formatted by clicking the
configure button, from the Settings screen.
 
Make sure to configure the export before exporting the first time.
 
Browse for the Export path using the 'Browse' button to the left of the 'Export Path' text box. Enter a
descriptive name for the file to be exported and click 'OK' to start the export.
 

.
 
 
Configure the Text Export
Click the 'Configure' button to customize the format of the text file that will be exported. This will launch
the EZ-Scan Text Export Wizard.
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The settings that you are going to set for this export will be saved, so you can reuse them. First enter a
 name for the configuration file.
 

 
This screen will allow you to define the format of your file.
Export Type
You have 2 choices

• Delimited Fields ( fields will be seperated with a character that you specify, typically a comma)
• Fixed Length fields (fields will have a fixed starting position and length)

 
General Settings
Select the date format that you would like any date fields exported in.
 
Check the 'Include decimal in numeric fields' check box if you would like the data to contain decimals.
 
Delimiters
Here you can define delimiters for each field, along with extra delimiters for text and date fields. The only
required delimiter is the field delimiter.
 
Fixed Length Options
If you choose the Fixed Length option, the options at the bottom of the screen will change to show more
fixed length options.
 



 

 

 
You can choose to justify the data in the fields to the left or right, and can specify dates, text, and numeric
fields differently. ex.(left justification 123500000 right justification 0000012345).
 
You can specify the character used to pad the data when the data does not fill the entire length of the
field. Typically "0" or space.
 
 
Fields to Export
 



 

 

 
Here you will specify which fields, and in which order they will be exported. The list on the left contains
all the available fields in the EZ-Scan database, along with 2 special fields (Front Filename and Back
Filename).
Highlight the fields that you would like to export and click the '>' button to move them to the left list. You
can use the "<" button to move a field back.
 
You can set the order of the fields by selecting a field in the left list and clicking the arrow keys to move it
up or down in the list.
 
The double arrow fields "<<" and ">>" will move all fields.
 
You can also add a prefix or suffix to the fields being exported. If you are using delimited fields you will
see the following screen:
 



 

 

 
 
If you are using fixed length fields you will see the following screen with the addition of the length column
to define each fields length.
 



 

 

 
Click 'Finish' to save your settings.
 



 

 

EZ-Scan Text Export
 
This export will export the data  in the grid  in an ASCII text file which can be formatted by clicking the
configure button, from the Settings screen.
 
Make sure to configure the export before exporting the first time.
 
Browse for the Export path using the 'Browse' button to the left of the 'Export Path' text box. Enter a
descriptive name for the file to be exported and click 'OK' to start the export.
 

.
 
 
Configure the Text Export
Click the 'Configure' button to customize the format of the text file that will be exported. This will launch
the EZ-Scan Text Export Wizard.
 

 

export~1__ezscan~2.htm?drex_3902#configure


 

 

The settings that you are going to set for this export will be saved, so you can reuse them. First enter a
 name for the configuration file.
 

 
This screen will allow you to define the format of your file.
 
Export Type
You have 2 choices

• Delimited Fields ( fields will be seperated with a character that you specify, typically a comma)
• Fixed Length fields (fields will have a fixed starting position and length)

 
General Settings
Select the date format that you would like any date fields exported in.
 
Check the 'Include decimal in numeric fields' check box if you would like the data to contain decimals.
 
Delimiters
Here you can define delimiters for each field, along with extra delimiters for text and date fields. The only
required delimiter is the field delimiter.
 
Fixed Length Options
If you choose the Fixed Length option, the options at the bottom of the screen will change to show more
fixed length options.
 



 

 

 
You can choose to justify the data in the fields to the left or right, and can specify dates, text, and numeric
fields differently. ex.(left justification 123500000 right justification 0000012345)
 
You can specify the character used to pad the data when the data does not fill the entire length of the
field. Typically "0" or space.
 
Fields to Export



 

 

 
Here you will specify which fields, and in which order they will be exported. The list on the left contains
all the available fields in the EZ-Scan database, along with 2 special fields (Front Filename and Back
Filename).
Highlight the fields that you would like to export and click the '>' button to move them to the left list. You
can use the "<" button to move a field back.
 
You can set the order of the fields by selecting a field in the left list and clicking the arrow keys to move it
up or down in the list.
 
The double arrow fields "<<" and ">>" will move all fields.
 
 
You can also add a prefix or suffix to the fields being exported. If you are using delimited fields you will
see the following screen:
 



 

 

 
 
If you are using fixed length fields you will see the following screen with the addition of the length column
to define each fields length.
 



 

 

 
Click 'Finish' to save your settings.
 



 

 

Reliafund Export
 
Contact PST for details



 

 

SER Check Export
 
This Export will can be used to send data to the Synergy Document Management system.  
 
Locate the documents that you would like to export by searching for them with the 'Find' dialog box.
 
Choose File>Export>SER Synergy check
 
The 'Confirm Export Settings' dialog appears pre-filled with settings set up on the 'Export' tab of the
options screen.
 
Configure specific settings
Click the 'Configure' button to access the settings specific to this export.
 
Check with the Administrator of your synergy system for help with the settings for this export.
 
Autofilename
If you chose to separate batches when exporting, you must choose 'Automatically generate export
filename' from the 'Export' tab of the options screen. If you don't will receive this message when you
attempt to export, giving you an opportunity to set the option.
 
Output
2 files will be created in the directory specified for your export path. If autofilename is used the files will
be named with the following naming convention 'IMG00001', where 'IMG' is a prefix and '00001' is a
sequential number.



 

 

SER Doc Export
 
This Export will can be used to send data to the Synergy Document Management system.  
 
Locate the documents that you would like to export by searching for them with the 'Find' dialog box.
 
Choose File>Export>SER Synergy Doc
 
The 'Confirm Export Settings' dialog appears pre-filled with settings set up on the 'Export' tab of the
options screen.
 
Configure specific settings
Click the 'Configure' button to access the settings specific to this export.
 
Cabinets, Doc Types, and Delimiters
You can add Cabinets, Doc Types, an Delimiters to the drop down list. Simply type in the desired name
and click 'Add'. You can remove an item by selecting the item and clicking 'Remove'.
 
Mapping export fields
The grid on this screen is used to map the EZ-Scan database fields to the fields exported. Choose the
fields to export from the EZ-Scan database by checking the box in the 'Export' column. You can change
the name of the field in the export file. Simply edit the name in the 'Index Name' column.
 
Check with the Administrator of your synergy system for help with the settings for this export.
 
Output
2 files will be created in the directory specified for your export path.



 

 

XML Export
 
The EZ-Scan XML Export will upload images and data to a remote server using an HTTP Post
 
Before using the XML Export for the first time, you will need to configure it. Go to Tools>Options and click
on Export in the tree view on left of the options screen.
 
Select EZ-Scan XML Export from the Export Format drop down box and then click the 'Configure' button.
You will see the following configuration dialog box.
 

 
Export URL
This is the URL of the page that will process the uploaded image.
 
Username and Password
This  is the username and password that will be sent in the XML data to the processing web page.
 
Processing Web Page
The page specified in the export URL property will have to process the uploaded image and associated
data. The image and data will be sent in the following format:
 
XML Export Format
<?xml version="1.0" encoding="UTF-8"?>

<PostScannedCheck>
<UserName>username</UserName>
<Password>password</Password>

<ImageFrontEncoding>tiff</ImageFrontEncoding>
<ImageFrontData> [Base 64 image data for front image] </ImageFrontData>
<ImageBackEncoding>tiff</ImageBackEncoding>
<ImageBackData> [Base 64 image data for back image] </ImageBackData>
<MICROCR>t063108680t1140 12345678o     a0000005000a</MICROCR>
<ItemNo>1</ItemNo>
<Route>063108680</Route>
<Account>12345678</Account>
<CheckNo>0000000000001140</CheckNo>
<TranCode></TranCode>
<Amount>50</Amount>
<IDCompany>PST</IDCompany>
<DateProcess>5/5/2006</DateProcess>



 

 

<IDBatch>Test</IDBatch>
</PostScannedCheck>
 

XML response
The page processing the data will have to save the data to a database and save the image locally. If the
upload is successful it should suppy the following text in its response. The XML export will check the
response to verify a successful upload.
 
Successful response = <?xml version="1.0" encoding="UTF-8"?></ProcessScannedCheckSuccess>
 
Any other response will be displayed to the user for error reporting.
The following tags will be checked and displayed  in the case of an error
<Code></Code>
<Description></Description>
 
If neither a successful response nor the error tags are found, then the entire response will be displayed to
the user.
 
Contact PST if you need help setting up your upload page.
 
Exporting items
The XML export will export the items currently in the grid. You can export when a batch is complete or do
a search to retrieve the items for the export.
 
You will see a confirmation dialog box before the export begins.
 

 
Verify the url and click 'OK' to start the export.
 
When complete you will get a message like this:
 

 
Export log file



 

 

Click 'Yes' to view the log file. The following information will be logged for each successful upload
 
(20060508 16:52:46) Successful Upload to http://www.ez-scan.net/ezwebview/ezwup.asp
Function: clsExpXML.Process
Date Process: 5/5/2006 IDCompany: PST Batch: Test Item: 1
 
Any errors that occur will also be logged.



 

 

 



 

 

 



 

 

Precision Software Technologies, Inc.
EZ-Scan Quick-Start Guide

 
 

Starting EZ-Scan-
Before running the software, install the scanning hardware. See 'Installing Hardware' for details.
 
Start the EZ-Scan application by double-clicking on the EZ-Scan icon.
 

 
If this is the first time that you have run EZ-Scan, the Startup Wizard will run. It will help you set the initial
settings needed to get up and running.
 
The EZ-Scan main screen will appear.  From the main screen you can choose to Scan or Find items, as well
as print Reports and set program Options.
 



 

 

 
 
Scanning Items -
Place the items you wish to scan in the feeder of the scanner and then click the Scan button to bring up
the Batch Properties dialog.  Enter the Batch ID you would like to use.  The Batch ID may consist of any
alphanumeric sequence that would uniquely identify the grouping of documents you intend to scan.  The
Process Date defaults to today’s date.  Click OK and the items will immediately begin scanning.
 



 

 

 
 
While scanning, items will be displayed on screen and added to the Item Listing in the order scanned.  Once
all items have been scanned, no further action is necessary.  All items are saved as they are scanned.  You
may now Find, Print, or Verify any of the scanned items.
 



 

 

 
 
Finding Items –
To find an item, click the Find button to bring up the Find Item dialog.  Enter as much or as little information
as you know about the item your looking for and then click Find.  The more information entered, the more
narrow the search results.  In this example, we’ve entered “1137” as the Check No. to find.  Any item with a
check number of “1137” will be returned.
 



 

 

 
 
 
Our search for check number “1137”, yielded one result, which is immediately displayed.  You may now edit,
delete, email, export, print, or verify this item.  Note:  Available features depend on which version of EZ-
Scan is being used.
 



 

 

  
 
You may also search for items by the Batch Properties.  In this example, we entered “Batch 1” as the Batch
ID.  Any item with a Batch ID of “Batch 1” will be returned.  If you reuse your Batch IDs, it would return every
item ever scanned with a Batch ID of “Batch 1”.
 



 

 

 
 
Our search for Batch ID “1”, returned ten items, the first of which is immediately displayed.  You may now
click on each item to switch the image displayed to find the item you want.
 



 

 

 
 
 
Printing Items –
With at least one item in the Item Listing, clicking the Print button will display the Print Options dialog.  From
here you may define how your images are printed.  We’ve set our Rows to 5 and Columns to 2 which will
generate pages with checks two across and five down.
 



 

 

 
The print options we chose would produce a full-size page like this:
 



 

 

 



 

 

Getting Help –
For more information, please use the online help by pressing F1 or choosing one of the help options from
the About menu.
 
 

If you need technical support, please contact us via the following:
 

Internet: http://www.pstezscan.com/
Email: support@pstezscan.com

Phone: (813) 996-5500
Fax: (813) 818-996-5600

 
 

http://www.pstezscan.com/
mailto:%2520support@pstezscan.com


 

 

 



 

 

Startup Wizard
 
Welcome Screen
 

 
The EZ-Scan Startup Wizard will run the first time that you run EZ-Scan. It will help you set the initial
settings that you will need to use EZ-Scan. You can also access it later under the Help menu on the main
menu.
 
 
License Check
 

 



 

 

The next screen of the Startup Wizard will check to see if you have a valid license key for the software,
and what Feature Package of the software that you have a license for. There are 4 different editions of
EZ-Scan.

• Lite
• Standard
• NP
• Professional
• Remit

 
Make sure that you have your key installed before running EZ-Scan. If you did forget to install your key
before running EZ-Scan, you can install the key at this point, and click the 'Read Key' button.
 
If you do not have a key, the software will load in Demo mode. You can still use the software with limited
features in Demo mode.
 
 
Database location
 

 
You can choose a database  template when creating a new database. By default a 'Checks' database will
be created, but you can  choose templates for a specific need from the dropdown. Some choices are:

Checks           Template Choose this if you will be scanning primarily checks
ACHExport     Template Choose this if you will be using the ACH export
Documents     Template Choose this if you will be scanning full page documents
Ivory                 Template Choose this if you will be importing data from an Ivory system
IvoryProVer2  Template Choose this if you will be importing data from an Ivory 2.0 system into EZ-
Scan Pro
 

A custom template can be created for you if you have special needs.
 



 

 

On the this screen you will tell EZ-Scan where you would like to store your data. Click the browse button
to select the location. By default it will be stored in 'C:\EZ-Scan\EZScan.mdb'.
 
 
Image Storage Location
 

 
 
Now tell EZ-Scan where you would like to store your images.
 
You will have this choice in all editions of EZ-Scan except 'Lite'. With 'Lite' you can only store images in
the database.
 
For all other editions of EZ-Scan you have 2 choices.

• Store images in the database
• Store images in files
•  

Images in database
Choose this option if you do not need long term storage. The database will hold approximately 150,000
to 175,000 images and data for those images. It is a convenient option if you only need to store your data
and images for a short period of time. You can purge data and images using the 'Purge Data' feature
under the 'Tools' menu.
 
Images in files
Choose this option to store the images in separate images files. This is the default setting in all but the
Lite Edition of EZ-Scan.
Click the 'Browse' button to select the location that you would like to use. By default it will save the
images in 'C:\EZ-Scan\Images\'.
 
 
Scanner Selection



 

 

 

 
Choose the scanner that you will be using from the list of available scanners in the dropdown list. If
you are unsure of which device to choose, the Scanner Drivers page will give you more details.  If the
scanner is already attached and the drivers have been installed, you can also click the 'Configure' button
to set specific settings for your scanner.  See the 'Installing Hardware' section of the help file for more
information on installing your scanner
 
 
Required Fields
 

 
Here you can choose the fields that you would like to display in the 'Data Verification' program. Just check
 the fields that you require.
 
 



 

 

Export Format
 

 
EZ-Scan comes with different export formats built in. You can choose the one to set as your default
export here. The other export formats will still be available from the file menu if needed. The following
export formats are available with EZ-Scan.

• EZ-Scan database export
• EZ-Scan text export
• SER Synergy Check export
• SER Synergy Doc export
• Full Text export
• EZ-Scan Image Export
• EZ-Scan Check 21 Export
• PST ACH Export
• PST BAI Export
• Reliafund Export
• XML Export

 
EZ-Scan can have custom exports created to fit your particular needs if the included exports don't meet
your needs. Contact Precision Software Technologies, Inc for details.
 
 
Finish
 



 

 

 
Just click 'Finish' to start EZ-Scan or click the 'Back' button to review your choices. You can click 'Finish'
at any time during the Startup Wizard to go straight to EZ-Scan.
 



 

 

Getting Started
 
Thanks for choosing EZ-Scan 5.0.
 
First install the EZ-Scan software. You can install the software without a key, but it will run in Demo Mode.
This will allow you to use the software for 45 days.
 
Insert your EZ-Scan software in the CD Rom drive. The installation program should start automatically.
If it doesn't start automatically, browse to the CD Rom drive in My Computer or Windows Explorer and
double click on Setup.exe.
 
The newest version of EZ-Scan Software can be downloaded at www.pstinc.net/pub
 
The installation program will guide you through the installation of EZ-Scan.
 
With your EZ-Scan CD you will receive a hardware key that enables your software. Simply plug  the USB
key into an available USB slot.
 
A USB key.

 
When you start EZ-Scan for the first time, the 'Startup Wizard' will run to help you set your initial settings.

http://www.pstinc.net/pub


 

 

 



 

 

Auto Import
 
Overview
The Auto Import is used to automate the EZ-Scan Database import to run on a scheduled basis, using the
task scheduler in Windows.
It is typically run overnight to import data to the main database from branch databases.
 
Go to Start>All Programs>Accessories>System Tools>Scheduled Task to open the Task Scheduler.
This will open an explorer window with your scheduled tasks. Click on Add Scheduled Task to start the
Scheduled Task Wizard. In Windows 7 go to Start and type Task Scheduler into the search box.
 

 
 

 
The next screen will ask you to select the program to schedule



 

 

 

 
Click 'Browse' and browse to C:\EZ-Scan\Tools\pstAutoImpDB.exe
 

 
Name the task and choose when to run.
 



 

 

   
 
The task scheduler will need to run as a user that has rights to both the databases being imported as well
as the database being imported into, and rights to the locations where all images are stored. NOTE: If the
does not have rights to any of the necessary files and directories, the import will fail.
 



 

 

 
The last screen will confirm your settings.
 

 
 
Configure Auto Import Settings
The Auto Import settings are contained in the pstAutoImpDB.ini in the Windows directory. It needs to be
edited to tell the program what jobs to run and to set the properties of each job.
 
Open the file in notepad and edit the settings for your job or jobs. You can have just as many jobs
scheduled  as necessary. Just add a new job section for each one.
 
Here is an example of the entries in the INI file.
 



 

 

[AutoImpDb]
Silent = 0
 
[JOB1]
Silent = 1
Delete = 1
DateFrom=
DateTo=
ImportImagePath=C:\EZ-Scan\Test\Images\
ImportPath=C:\EZ-Scan\Test\
ImportFilename=EZ-Scan.mdb
DestinationDatabase=C:\EZ-Scan\EZ-Scan.mdb
LogFilePath=C:\EZ-Scan\
IgnoreImportedFlag = 0
[JOB2]
Silent = 1
Delete = 1
DateFrom=
DateTo=
ImportImagePath=C:\Ez-Scan\TestiMPORT\iMAGESBranch2\
ImportPath=C:\Ez-Scan\TestiMPORT\
ImportFilename = Branch2.mdb
DestinationDatabase=C:\Ez-Scan\TestImport\Main.mdb
LogFilePath=C:\Ez-Scan\
IgnoreImportedFlag = 0
 
 
The jobs must be named sequentially  [JOB1],[JOB2],[JOB3], etc and will be run in the order listed.
 
Silent
Silent under the heading AutoImpDb will run the Auto Import in silent mode with no user interface.
Silent under each job section will overide the setting in AutoImpDb. Typically Silent will be set to 1 (True)
 
DateFrom DateTo
DateFrom and DateTo refer to the Date Process of the items in the database. It will allow you to import
items in a specific date range.
 
ImportImagePath
This is the path to the images being  imported.
 
ImportPath
This  is the path to the database being imported.
 
ImportFile
This is the filename of the database being imported.
 
DestinationDatabase
This is the path and filename of the database that the data and images will be imported into.



 

 

 
IgnoreImportedFlag
This  will allow items to be imported  that were imported previously, if set to 1 (True)
 
LogFilePath
This is the directory that the log file will be created in.
 
Once the settings are complete the auto import is ready to go and will run as scheduled in the Task
Scheduler. The log file will contain the details  of the import.



 

 

EZ-Scan Check 21 Import
 
EZ-Scan can import data from a x9.37 Check 21 file.  This import will import check data as well as
endorsement data. The endorsement data will be passed along if an outgoing x9.37 file is created using
an item imported using the Check 21 import. The bundles in the batch will be used to create batches in
the EZ-Scan database.
 
Click File>Import>Check 21 Import.
You will be presented with the following screen.
Browse to the file to import by clicking the ellipses button.
 

 
Click 'OK' to start the import process.
 
Forward items will append _FWD to the Company ID
Return items will append _RTN to the Company ID



 

 

EZ-Scan Image Import
 
The EZ-Scan Image Import allows you to import images into the EZ-Scan system. The items will be
indexed with batch field data for easy retrieval.  Used in conjunction with the PST MICR OCR plug-in, or
the PST Check Recognition plug-in, all check fields can be added to the database with little data entry by
the user when importing check images. It can also be used with the PST OCR Mitek plug-in or the PST
Barcode/OCR Plug-in to read other fields or barcodes on the imported documents.
 
Select File -> Import -> EZ-Scan Image Import
 
From this screen you will select the directory of images that you would like to import.
Note: Sub directories will not be imported.
 
Click the browse button to select the directory that you would like to import. Beneath the folder text box a
count of available images will be updated after you select the directory.
 

 
Click 'Next' and you will be presented with a list of available images from the chosen directory. EZ-Scan
supports .TIF and .JPEG images. You can filter the list by selecting the type that you would like to import
from the 'Files of type' dropdown box.
 
Check the checkbox next to each image that you would like to import. Click the 'Select All' button to select
all images.
 



 

 

 
All images imported will be indexed with Batch field data. Enter the values on the next screen.
 



 

 

 
Click 'Next' again and you will be taken to the summary screen. Make sure the information is correct and
then click 'Finish' to start the import.
 



 

 

 
Once the import is complete you can retrieve the items by doing a 'Find' using the Batch data for criteria.
 
To run one of the plug-ins mentioned above, do a 'Find' using the Batch data for criteria. This will fill the
grid with the items imported. Then, from the Plug-Ins button on the Toolbar, select the desired plug-in to
run on the images.



 

 

EZ-Scan Opex Import
 
The Opex import will import .oxi files created when scanning documents on an Opex brand scanner.
 
This will import data and images and convert them into EZ-Scan format.
 
 
Go to File>Import>Opex OXI from the main menu
 

 
You can click on the OSD job folder ellipsis and it will load the available oxi files in the oxifile box, or you
can click the ellipsis next to the oxi file box to browse to the file.
 
 
Opex Oxi options:
 

 
You can set a default Job folder as well as map oxi fields to EZ-Scan database fields.
Ex. CustName from the oxi file could be mapped to a field called Payor in the EZ-Scan database.
 
Click OK to start the import. The oxi file has an image path contained within it. If the images cannot be
located at that address, the program will attempt to find them in the same directory as the oxi file.
 



 

 

 
When the import is complete, you will have the option to open the item in EZ-Scan.
 



 

 

Generic Text Import Wizard
 
Select File -> Import -> Generic ASCII from the menu.
 
This will start the Generic Text Import Wizard.
 

 
You have the option of creating a new import or loading an existing import. At the end of this process you
will able to save all of your import settings to a file to use again later.
 
If you choose to load an existing file you simply select it in the dropdown list of available import files and
click the 'Load Saved Import' button. The last file that you have imported will prefill the 'File to Import' text
box. If you choose to import a different file, you can click the 'Browse' button to the right of the textbox to
locate the file that you would like to import. You can then simply click the 'Finish' button and the import will
run with the settings saved in the file that you have selected.
 
If you choose to create  a new import you will need to click the 'Browse' button to select the file that you
would like to import. Click 'Next'
 
 
Choose Format
 



 

 

 
You have 2 choices for the format of the file:

• Delimited
• Fixed Width

Make your selection and click 'Next'
 
 
Enter Batch Information
 



 

 

 
Batch information is required for the data being imported. It can be obtained in 3 ways:

1. The data can be imported as one batch with the user putting the batch information in the
textboxes provided.

2. The batch information can be mapped to fields in the file being imported.
3. The batch information can be parsed from the image filename field. This is used to import data

in the 'Quickive' format.

 
 

Fixed Width Settings
 



 

 

 
If you chose Fixed Width for your file, you will have to define the Start Position and length of each field.
 
 
Delimiter and Field Mapping options
 



 

 

 
If you chose the delimiter option on the second screen, you will need to set the options for the delimited
file.
Field Delimiter ( disabled if you chose Fixed length)

Choose the delimiter from the dropdown list or type the delimiter in, if it is not in the list. When you choose the
delimiter, the file will be reparsed and loaded into the grid. You can check the grid to make sure that the data is
parsed properly.

Text Delimiter ( disabled if you chose Fixed length)
Text fields can additionally be delimited with another character. Choose the character from the
dropdown or type it in.

Date Format
Choose the format for date fields in your file.

Skip Header Rows
If your file has header information, enter the number of rows to skip to get to the data. Click the
reload grid button to reparse the file skipping the header information.

Mapping data fields
At this point you will need to map the fields in the file to fields in the EZ-Scan database.
You do this by highlighting the field in the grid, and selecting the field in the 'Available Fields' drop
down that you would like to map it to. The column heading will change to the field name in the EZ-
Scan database that it is mapped to. You do not have to map all the fields in the file. If you do not
map them, they will not be imported.
 
 

Save your settings
 



 

 

 
If this will be a frequently used import, give it a name and save the format. Make sure to click the 'Save'
button.  Then click finish to import the file.
 
 
NOTE: Don't forget to  click 'Save'
 

 
You will receive a confirmation screen when the import is completed.
 



 

 



 

 

Import an EZ-Scan Database
 
 
Select File -> Import -> Import EZ-Scan Database from the menu.
 

 
Import Settings
You can import all data in the database or just data with a Process Date within a selected date range.
Import path
This is the path to the database that you would like to import.
Import file
This is the filename of the database that you would like to import.
Import image path
This is the storage location of the images that corresponds to the data in the database that you are
importing.
 
If there are fields in the source database that don't exist in the destination database, you will be notified
before the import begins.
 
At this point you can continue the import and the missing fields will be skipped, or you can cancel the
import so that you can add the fields to your database. NOTE: Custom item fields can only be added in the
Professional version of EZ-Scan.
 
The import progress will be logged in the Import Status Dialog.
 



 

 

 
 
When the import is complete you will see a confirmation message.
 

 
You can automate the database import with the EZ-Scan Auto Import.



 

 

Ivory Import
 
The EZ-Scan Ivory Import is used to import data and images from Bell and Howell  Ivory Check Scanning
 systems. The Ivory import supports importing from from Ivory Version 2 and 3 as well as Ivory Archive
CDs.
 
If you going to import items from an Ivory system you need to create your database using the Ivory ( for
EZ-Scan standard for version 2 or 3) or IvoryProVer2  (for EZ-Scan professional importing Ivory Version 2
databases.) database template in the New Database Wizard or the Startup Wizard. This will create all the
necessary fields in the EZ-Scan database to import the Ivory data. You can still use the Ivory Import with
a standard database but some data will not be imported.
 
Go to File>Import>EZ-Scan Ivory Import. You will see this dialog box:
 

 
 
Select the version of the Ivory software that  you are importing from.
 
Version 3.0
The 3.0 version uses a data file to import the data. Simply browse to the location of the ivData.txt file
using the Ivory 3.0 Archived option.
 
Check the appropriate radio button if you would like to import the images into the EZ-Scan system
(recommended) or to leave the images in their original location. If you leave the images in the original
location and that happens to be a CD, you will be prompted in EZ-Scan to insert the proper CD volume in
the CD drive when retrieving items that have been imported.
 
Click 'OK' to start the import process.
 



 

 

Version 2.0
The 2.0 Version needs a few more directory settings. Just click the browse button next to each one to
locate the proper directories. You will need to set the CD directory setting even if you are not importing
items from CDs.
 
Check the appropriate radio button if you would like to import the images into the EZ-Scan system
(recommended) or to leave the images in their original location. If you leave the images in the original
location and that happens to be a CD, you will be prompted in EZ-Scan to insert the proper CD volume in
the CD drive when retrieving items that have been imported.
 
Click 'OK' to start the Import process
 
If there are fields in the ivory database that dont exist in the EZ-Scan database, you will be receive a list
of fields that will not be imported. If you have used a EZ-Scan standard edition software and a default EZ-
Scan checks template database the following fields will be missing:
 

 
You will need to upgrade to EZ-Scan professional edition to import all Ivory fields.
 
If you are using profession edition EZ-Scan software with the IvoryProVer2 database you will not see this
message. All fields will be available.
 
When importing, an image in the Ivory System may be unavailable. EZ-Scan will prompt you when it
encounters a missing image during the import. You will have 3 choices:
 



 

 

 

1. Locate the volume that contains the images and insert it in the CD Rom drive designated  in the
Ivory Import confirmation screen shown above.

2. Ignore missing images for this volume. The Import will continue to import all data ignoring
missing images. (This way you won't have to insert the image cd for each volume while
importing if you are not importing the images into the EZ-Scan system). If you make this
selection you can also choose to ignore missing images for all volumes so that you won't be
prompted again.

3. Skip this volume. The current volume will not be imported into the EZ-Scan system.

 
Once imported you can retrieve the items imported by doing a Find.



 

 

 



 

 

Locating Documents
 
To locate an item you can use the Find dialog box. You can get to the Find dialog in a few ways:

• Click 'Find' button on the right of the screen
• Click on the 'Find' icon on the toolbar
• Hit the F3 button
• Hit Ctrl + F
• Click Edit>Find from the main EZ-Scan menu.

 
Enter as much or as little information as  you know about the item your looking for and then click Find.
 The more information entered, the more narrow the search results.  
 
Wildcard Characters
You can use the "*" character  as a wild card when you only know part of a value for a field. This will only
work on text fields. For instance, if you know that an Account number starts with TR768 but don't know
the whole number, you can search for TR768 *. This will return any account number that begins with
TR768 such as TR76811777 or TR768 YSJ777. You can use the wild card character at the beginning,
end, or on both the beginning and end of the text.
 
You can use a > or < character when searching for a numeric fields. For instance if you are looking for all
items with amount less than 100 dollars then search for <100.
 

 
Results of you search will be displayed in the grid on the main screen.
 
You can use the search feature to retrieve items to Verify, Export, Printing, Emailing or any other process
that you would like to use the results for.
 
If you have the Professional  or Remit Edition, the custom fields that you add to the program will also be
available for Searching.
 



 

 

Each field has a property called 'Enable Range on Find'. When set to True, this will create a 'Field From'
text box and a 'Field To' text box on the find screen. ex See the Process Date field in the image above.
This will allow you to find data within a certain range.
 
ex. Amount From = 100 and Amount to = 200 will retrieve all items where the Amount field has a value
greater than or equal to 100 AND less than or equal to 200.
 
Field properties can be set on the Add/Edit Field dialog box that can be reached by clicking edit on the
selected field from the 'Item Fields' or 'Batch Fields' screen of the 'Options' dialog.



 

 

 



 

 

Batch Fields Option Settings
 
Select Tools -> Options from the main menu.
 

 
Prompt for Batch ID
If the 'Batch ID' checkbox is checked, the user will be prompted to enter a Batch ID on the Batch
Properties screen before scanning. If it is not checked a Batch ID will be automatically generated for each
new batch. The automatic Batch ID's will be numeric and sequential.
 
Recycle Batch ID dropdown
If you choose to have the Batch ID automatically generated, you can choose when the Batch ID will be
reset.
Your choices are:

• Daily
• Weekly
• Monthly
• Yearly
• Never

 
Prompt for Item Number
If you check the 'Item Number' checkbox, You will be able to designate the starting item number on the
Batch Properties screen before scanning. You can enter a default starting number in the 'Default Start'
textbox.
 



 

 

The following feature is available for Standard, NP. Professional, and Remit Editions of EZ-Scan. It is not
available for EZ-Scan Lite.
 
Adding Custom Batch Fields
The Batch Info tab will allow you to add custom fields to the Batch Properties screen. The Standard
edition will allow you to enter 5 custom Batch fields. The Professional and Remit version will allow as
many fields as your screen space will allow. Click the 'Add' button to add a custom field. See Add Custom
Fields for details.
 
Editing Custom Batch Fields
Each of the Batch fields have properties that can be edited. This will help you customize EZ-Scan for your
particular needs. To edit the field properties click the 'Edit' button. See Edit Custom Fields for details.
 
Removing Custom Fields
You can remove fields by clicking the remove button. It is recommended to edit the field properties,
instead of removing the field. You can remove the field from specific sections of the program by editing
the field properties, but it will be available if you need it in the future. See Edit Custom Fields for details
 
Move Up / Move Down
Using these buttons you can set the order that these fields  will be displayed on the Batch Properties
screen.
Simply highlight a field and click the 'Up' or 'Down' button to change its position in the list.



 

 

Export Option Settings
 
Select Tools -> Options from the main menu.
 

 
Export Format
EZ-Scan comes with many export formats. They are as follows:
 

• EZ-Scan Database Export
• EZ-Scan Text Export
• EZ-Scan Image Export

• SER Synergy Check export
• SER Synergy Doc export
• Full Text export
• EZ-Scan Check 21 Export
• PST ACH Export
• PST BAI Export
• Reliafund Export
• XML Export
• ATE Export
• CSP Export
• KLIK Export
• OFX Export
• QIF Export
• Quickive Export



 

 

• Reliafund Export
• Syngence Export

 
Choose the format from the drop down list. This will set the selected export as you default export. When
you click on the 'Export' button on the right of the main screen, or click the 'Export' icon from the toolbar,
this export will be run. The other exports will be available from File>Export> from the main menu.
 
Configure
If the current export has any custom settings to configure, you can set them by clicking the configure
button. The settings screen that is shown will vary depending on the export chosen.
 
Export path
This will be the directory that the export file will be written to, when exporting data. You can use the
browse button to select the export directory. This is optional. You can check the 'Prompt for path when
exporting' option to let the user enter the Export path when exporting.
 
If you enter an export path but don't check the 'Prompt for path when exporting' option, the user will not
be able to change the export path when exporting.
 
Automatically Generate filename
EZ-Scan can automatically generate a filename  for you if this option is checked. This is not available for
all exports.
 
Export file
If you enter a file name here, it will be used every time that the export is run. You can leave this blank
and check the 'Prompt user for filename when exporting' option to let the user set the file name when
exporting. Once again if you specify a file name here and  don't check the 'Prompt user for filename when
exporting' option, the user will not be able to edit the filename when exporting.
 
Prompt for Export on Between Batches
This will prompt the user  to export data from the current batch before starting a new one. Simply a
reminder for the user.



 

 

General Option Settings
 
Select Tools -> Options from the menu.
 

 
Open the following database
Browse to the EZ-Scan database that you would like to open when starting EZ-Scan. This typically gets
set with the startup wizard and doesn't need to be changed.
 
Connection Timeout
This is the amount of time in seconds that is allowed for a database connection to be established. Don't
edit this unless you have a problem.
 
Query  Timeout
This is the amount of time in seconds for a Query of the database to timeout. Don't edit this unless you
have problems.
 
Printing Report Header
Here you can define the Header Text for the built in EZ-Scan reports.
 
Show  running total when available
This will show a running total of items in the grid in the Status Bar.
 
Load batch values from grid
This will load the values from items in the grid when you start a new batch. If unchecked, only default
values will be loaded in the Batch Properties screen.
Load last batch on startup
This will load the last batch scanned into the grid when EZ-Scan is started.



 

 

 
Allow Grouping of items
If you check the 'Allow Grouping of Items' checkbox, you will get an additional 'New Group' button on the
right side of the main screen. This allows you to create sub grouping of items that belong together. This
is a useful option for linking items together, such as a check and a coupon. With this option enabled each
item will be assigned a group Id. Click the button before each group of items is scanned. The same group
id will be assigned to each item until the 'New Group' button is clicked again. This will also add a new
menu item to right click menu on the grid.
 

 
The 'Group selected items' and the 'Group' item under 'Find items from the same' menu are added. This
allows you to group items in the grid by selecting the items that you want grouped. It also lets you retrieve
items from the same group, as the one in the grid. For instance you could do a search for a check with an
amount value of 100 dollars. Once you retrieve the check you can right click on it and choose 'Find items
from the same' and 'Group'. This will retrieve the all the items from that group. To revert to the items that
were in the grid before doing the group find, choose 'Find items from the same'  and 'Revert to the last
query'
 
A Document recognition plug-in is also available that will automatically recognize document types and
assign group ID's automatically. Contact PST for details.
 
Enable History/Audit logging
When  checked this will log all critical activity that occurs in the program, such as deletions, opening and
creating databases, editing data, changing options, etc. Whenever an item is deleted or edited the current
data for that record is preserved in the audit table before the action takes place. In the Professional
version and higher the Username of the user logged in will be saved with each audit record.
 
Each action is saved in the table with an Audit type designation.
     Generic = 0
     Edit = 1
     Delete = 2



 

 

     Scan = 3
     Database = 4
     Settings = 5
     Find = 6
     Export = 7
     Import = 8
     PlugIn = 9
     Users = 10
     Report = 11



 

 

Item Fields Option Settings
 
Select Tools -> Options from the menu.
 

 
 The following feature is available for Professional Edition and Remit Edition of EZ-Scan. It is not
available for EZ-Scan Lite or Standard Edition.
 
Adding Custom Item Fields
The Verify  tab will allow you to add custom fields to the items that you scan. The Professional and Remit
version will allow as many fields as your screen space will allow. Click the 'Add' button to add a custom
field. See Add Custom Fields for details.
 
Editing Custom Item Fields
Each of the Item fields have properties that can be edited. This will help you customize EZ-Scan for your
particular needs. To edit the field properties click the 'Edit' button. See Edit Custom Fields for details.
 
Removing Custom Fields
You can remove fields by clicking the remove button. It is recommended to edit the field properties,
instead of removing the field. You can remove the field from specific sections of the program by editing
the field properties, but it will be available if you need it in the future. See Edit Custom Fields for details
 
Move Up / Move Down
Using these buttons you can set the order that these fields  will be displayed.
Simply highlight a field and click the 'Up' or 'Down' button to change its position in the list.
 
Verify when Exporting /Force Verify before Export



 

 

If Verify when Exporting is checked the data in the grid will be checked for missing data in required
fields. If there is any records that need to be verified the user will be prompted to verify the data before
exporting. If the Force Verify before Export is checked the user will not have a choice to skip the verify
process. If the user chooses not to verify the export will be cancelled. This will force the user to have valid
data before exporting.
 
Verify between batches
If Verify between batches is checked, the user will be prompted to verify data in the current batch before
starting a new batch. The user is given the option to verify, but is not forced to.



 

 

Options
 
Choose Tools>Options from the main menu or click the Options icon from the toolbar.
 

 
Click the following links for details on each tab of the Options screen.
 

• General Options
• Export Options
• Scanning Options
• Security Options
• Verify Options
• Storage Options
• Batch Info Options
• EZ-Scan.NET Options



 

 

Scanning Option Settings
 
Select Tools -> Options from the menu. Click on the Scanning tab.
 

 
Select Scanner(s)
Select  your primary imaging device from the drop down list of available scanners. By default the button
will have a caption of  &Scan. You can change this to suit your needs. The & symbol in the caption will
create a shortcut key for the button. &Scan will show up on the button as Scan, and the Alt +S shortcut
will trigger the key.
 
You can add a secondary imaging device if you have one. Select your secondary scanner from the drop
down list. This will add a second button with the caption that you designate on the right side of the main
screen. If you do not have a second scanner choose (None Available) from the list.
 
Configure
The configure button next to each drop down list will open an options screen for the scanner. Each
scanner has a different options screen with settings for that scanner. You can click F1 while on the
options screen for your scanner, to get additional help. Make sure that you have the scanner connected
and powered on before starting the computer. NOTE:  If you click the configure button and the scanner is
not connected the options screen will take a long time to show up as it attempts to initialize the scanner.
 
Printer Text
The printer text can be set from this screen. Simply type the text that you would like printed on the check
in the text box, or select from the list of previous entries. If you want to insert dynamic data from 'Batch'
fields you can add them by clicking the elipsis button next to the Printer Text dropdown. Select the field
from the list that appears. The batch data will be inserted at the location of the cursor in the Printer Text
dropdown. You can also set the Printer Text  from the scanner configuration screen  which you can open



 

 

by clicking the configure button.  You will not have the options for adding the batch fields from the scanner
configuration screen. You only have the option of adding the date to the Printer Text from there by typing
in the following macro {DATE}.  It will be replaced by the current date when printing.  
 
NOTE: From the scanner configuration screen, you must check the 'Application supplies Printer Text'
check box to use the printer text and dynamic fields from the EZ-Scan options screen.
 
NOTE: Using the dynamic 'Batch' field printing will slow down the performance of the  scanner. For
maximum speed you must use the printer text from the scanners configuration screen. If you want to use
the Printer Text from the scanner configuration screen, make sure to uncheck the 'Application supplies
Printer Text' check box and clear any text from the EZ-Scan Printer Text.



 

 

Security Option Settings
 
Select Tools -> Options from the menu.
 
 
Standard Security
 

 
EZ-Scan Standard Edtion has a limited amount of security options. You can require a password for 3
operations.

• Change Options / Purge
• Scan / Export
• Retrieve

 
If you check the box and add a password the operator will be required to enter a password for each of
these operations.
 
 
Professional Security
 



 

 

 
Add User
EZ-Scan Professional Edition comes with a more robust Security system. You can add Users and assign
rights to each individual user. To add a user, click the 'Add' button.
 

 



 

 

You will be able to assign rights profiles by choosing from the drop down menu.  There are some
predefined profiles in the drop down box  that will check the appropriate boxes for each user type. Check
or uncheck additional rights as needed.

• Administrator
• Default User
• Scanner User
• Verify User
• Viewer User

 
NOTE: EZ-Scan will make sure that you add an Administrator user with full rights first. You may lock your
self out of required features if you don't.
 
Users can be disabled without having to delete them. Click the Disable this account box on the User
Properties dialog box.
 
Edit User
Highlight a user in the grid and click the 'Edit' button. This will bring up the User Properties screen to edit
options for this user. Click 'OK' to save changes.
 
Remove User
Highlight a user in the grid and click the 'Remove' button to remove them from the system. You can
optionally edit the User and mark the user as 'Disabled' this will deny the user login rights, without
deleting the user from the system.
 



 

 

Storage Option Settings
 
Select Tools -> Options from the menu. Click on the Storage tab.
 

 
Image storage
You can choose to store the images in the database or in separate images files in all editions of EZ-Scan
except EZ-Scan Lite. Your only option with Lite is to store images in the database.
 
Storing images in the database is a convenient option if you do not need long term storage. All data
and images will be stored in one database file. Access databases have a 2 gigabyte size limit. This will
limit you to storing approximately 150,000 to 175,000 images in your database. The actual number will
depend on the size and design of your documents. You will need to purge items from the database to
continue scanning once the database has been filled.
 
Storing images in separate files is a more flexible solution. The images are stored in one of the following
formats to separate images files.

• Multi-page Tiff
• Single page Tiff (separate image)
• Glued Tiff (front and back image glued together in one image)
• Multi-page Jpeg
• Single page Jpeg (separate image)
• Glued Jpeg (front and back image glued together in one image)

 
When setting Storage Locations, you should only have one Storage Path in the list unless you have
archived your information to a CD or other media. If you need to change the location where the images



 

 

are stored, edit the Storage Location number 1. This is the main storage location. Do not add another
storage location. Only add an additional storage location for as a location for Archive. ex CD rom. All
images should be stored in storage location number 1.
 

 
Storage Path
Use the browse button to locate the directory that you would like to store your images in.
 
Description
Give a Friendly description of the storage location such as EZ-Scan Images
 
Device Type
You have 2 choices

• Standard (Aggregate) This is correct for most locations except Jukeboxes
• Push Down Use this if you are using a Jukebox and need the Volume name duplicated in the

path.

 



 

 

 



 

 

EZ-Scan Plug-Ins
 
EZ-Scan's most important and versatile feature is it's ability to run Plug-Ins from various insert points
within the application.
 
Plug-ins are customizable programs that can run from within EZ-Scan. They can be created to make
custom exports, reports, image processing, OCR readers, data lookups, or just about any kind or data or
image processing.
 
The Plug-Ins are managed in the Plug-In Manager. To get the Plug-In Manager go to Tools>Plug-
ins>Plug-In Manager from the main menu.
 

 
Insert Points
In the left pane is a tree view control that lists all of the available 'Insert points'. These are the places in
the application can run plug-ins. To add a plug-in simply click on the 'Insert point' that you would like it to
run at. Click the 'Add' button. A list of available plug-ins will drop down. Select the Plug-In from the list.
It will be added to the list box on the right. If you add more than one Plug-In to this insert point, you can
set the order that they will run by highlighting a Plug-In and clicking the up or down arrows on the right to
change its position in the list.
 
Run as After Process
Most Plug-Ins can be run against all the items in the grid by clicking the small arrow next to the Plug-In
icon on the toolbar and selecting the Plug-In from the list.
 
Configuring the Plug-In
Each Plug-In will have its own unique set of options or settings which can be set by highlighting the Plug-
In in the list and clicking the 'Configure' button.
 
Available Plug-Ins*

*PST Address Lookup Plug-In v1.0



 

 

This Plug-In will pre-fill customer data based on Account and Route Code data.
PST Barcode/OCR Plug-In v1.0
This Plug-In will read barcodes or will use OCR to read a data line on a document.
PST CAR  LAR Plug-In v1.0
This Plug-In will read the Courtesy and the Legal amount off a check.
*PST Check Recognition Plug-In v1.0
This Plug-In will read name, address, amount, date and check for a signature on a check.
PST Data Entry Plug-In v1.0
This Plug-In will give the Data Verification functionality while scanning.
PST Document Recognition Plug-In v1.0
This Plug-In will automate the grouping of documents, and identify checks and non-check documents.
PST Field Evaluation Plug-In v1.0
This Plug-In is used to Evaluate 2 fields in the database such Coupon Amount and Check Amount.
PST Image Validation Plug-In v1.0
This Plug-In is used to create a report of missing images.
PST Lotus Mail Plug-In v1.0
This Plug-In is used to send mail from Lotus Notes.
*PST MICR OCR Plug-In v1.0
This Plug-In will read MICR lines with an Optical Character Recognition engine.
 
*PST OCR Mitek Plug-In v1.0
This Plug-In will use OCR to read multiple fields in multiple zones on a document.
 
PST Parsing Plug-In v1.0
This Plug-In is used to parse data from one field into multiple fields.
PST Sorting Plug-In v1.0
This Plug-In will sort items scanned based on Route Code, Account Number, or entire MICR line, on
scanners that support sorting.
PST Verify Template Plug-In v1.0
This Plug-In is used set up Verification templates which can change required and show in verify
properties of item fields..
PST Virtual Encoder Plug-In v1.0
This Plug-In is used virtually encode the amount on an image when the image camera is downstream
from the encoder.
PST Virtual Endorser Plug-In v1.0
This Plug-In is used virtually endorse the back of an image.
PST Virtual Item Plug-In v1.0
This Plug-In is used to create a virtual draft for a data record. This can be used to submit 'data only'
records into EZ-Scan and create the images that correspond to the data.
PST Voice Verify Plug-In v1.0
This Plug-In will read field data for verification purposes.
 
*There will be an additional charge for some Plug-Ins.
** EZ-Scan Lite does not support Plug-Ins.
 
Developers
The Plug-Ins are COM objects written with a standard interface. Developers can create there own Plug-
Ins for EZ-Scan by implementing the interface for the Plug-In. Sample Code is available from PST.
 

http://www.pstinc.net/


 

 

 



 

 

PST Address Lookup Plug-In v1.0
 
This Plug-In will do a lookup on the Account and Route numbers read off of the checks and retrieve
customer information for that particular Account and Route and pre-fill the fields from the data in the
database. If more than one record of data exists for that Account and Route (ex. Husband and Wife share
and account) both records will be added to a grid which the user can use to fill the fields with one click of
the mouse. If the data does not match the data already in the database, the user can add a new record to
that Account and Route combination.
 
The Address Lookup Plug-In is typically run in the 'After an item has been saved' Insert Point'
 
 
Here are the Options for the Address Lookup Plug-In.
 

 
Lookup database - This the database that will hold the lookup data. In a typical installation you will not
need to change this setting.
 
Lookup table -  This is the table in the lookup database which will contain the lookup data. In a typical
installation you will not need to change this setting.
 
Checks Only - The Plug-In will only run on checks when this option is checked.
 
Check for Rejected Payments -  To use this feature you will need to add a field to the lookup database
specified above. This field can be updated by clicking the 'Edit Lookup' button. This field can be used to
reject items from specific customers or accounts.
 

 



 

 

When you run the plug-in, you will see this message if the lookup information for this item is tagged as
rejected.
 

 
Ignore 1 to 1 - If this option is checked, the Address lookup will automatically save the data for items
that have a one to one match in the lookup database. No user interaction will be required. The Address
lookup screen will only show on items that are missing required data. If the option is not checked, then the
Address lookup screen will show on all items, even ones that have values in all required fields. This will
allow the user to verify that the data is correct before moving to the next item.
 
Run Unattended - If this option is checked the plug-in will run unattended. If there is a one to one match
the data will be saved for the item. If there is no match or multiple matches then the data will not be saved
and the user will not be prompted to enter it.
 
Save on Enter - If this option is selected the plug-in will set the 'Save' button as the default control on the
Address lookup screen. Hitting the 'Enter' key will press the 'Save' button. Each time the save button is
clicked the record will be checked to see if all required fields have data. If any of the fields are missing data
the field will be highlighted and focus will be set to it. If all required fields have a value then the record will
be saved.
 
Here is the interface for the Lookup. This will appear as each item is scanned through, pre filled with the
matching data.
 



 

 

 
The next and previous buttons will take navigate you through the current set of records one by one. When
you click 'Save' it will find the next record with required data missing.
 
Add New - If there was no match or no correct match for the check, you can add a new record to the
Lookup database for the item that you are processing. Each route and account can have multiple lookup
records. For instance, a husband and wife may have the same route and account, but different payor
information on the check.
 
Private Account - This check box will denote that this is a private account. It is used to allow the data
to be retrieved from the lookup for this account. This option allows you to mark checks written from 'Bill
Pay' services as 'not' private. Most  'Bill Pay' services use the same route and account for many different
customers, so the route/account lookup cannot be used to identify these customers.
 
Find - If the record is not private or there is no match on the route and account, you can still do a
search on any of the fields to find a match for you record. Enter as much or as little data as you
would like and click 'Find'. If there are any matches then they will be displayed in the grid.
 



 

 

PST Barcode/OCR Plug-In v1.0
 
The Barcode /OCR Plug-In can read barcodes or read OCR A characters on a document. The zones and
fields are set up on the option screen.
It is typically run from the 'After an item has been Saved' Insert Point, or from the main menu.
 
When you click the 'Configure' button from the Plug-In Manager the Barcode OCR designer will be
displayed.
 

 
First use File>Open to bring a document into the designer.
 
If this is a document that has a text line to be read by OCR, like the document in example, you will
need to define the 'Zone' for the OCR engine to read. The 'OCR Zone' frame will be disabled if reading
barcodes.
 
Take your cursor and hold the left button while dragging to draw a box around the area to be read.



 

 

 
The coordinates of this box will be displayed in the OCR definition zone.
 
You must also choose the anchor location for these coordinates. This refers to the corner that will be used
as the starting point when defining the coordinates. Choose the corner that is most likely to be consistent.
If the coupon has a tear edge on the bottom then use the Top Left or Top Right as your anchor.
 
Field Parsing
The text line can contain multiple fields. The Plug-In can parse these fields and store the parsed data in
the proper data field.
 
Select an available field from the drop down list. Enter the starting position in the line in the 'Start' box.
Enter the length of the field in the 'Length' box. Click the 'Add' button to add it to the list.
 
In the above example '105234SGM' will be saved to the 'Account' field. '1262' will be saved to the
'CheckNo' field.
 
IMPORTANT: Click File>Save Configuration when you are finished setting up your document.
 
The option screen is available under Barcode>Settings or OCRA>Settings.
 
Here are the general options for the Barcode OCR Plug-In.
 

 
'Watch only non-checks' will  keep the Plug-In from running on checks, to increase speed.
 
'Retain and save data between recognized documents' will update the check documents that follow a
 recognized document with the data read from the recognized document.  This can be useful for saving a
customer account number with the corresponding check.
 
This Plug-In can be used in conjunction with the PST Document Recognition v1.0 Plug-In which will
automatically group checks and coupons for Remittance processing.
 
 



 

 

Here are the OCR specific options.
 

 
Select the appropriate Font size and check the check boxes that apply to the data in your text line. Set
the confidence threshold to determine how high the confidence of the OCR needs to be to save the data
that was read. If the OCR reader returns with a confidence lower than the setting that you have chosen
the data will not be saved.
 
 
Here are the Barcode specific options.
 

 
Choose the Barcode Font from the drop down list. If you do not know the font check with the
manufacturer of your document to determine the font.
 
The barcode reader can read multiple barcodes on one document. Enter the maximum number of
barcodes that will appear on the document.
 



 

 

Enter the minimum number of characters that will be contained in the smallest barcode on the document.
 
Leave the following settings at the default settings unless you have trouble. These setting are advanced
and can be detrimental to your reads if set incorrectly.
 

• Min Thickbar: The minimum size in pixels of the thickest bar in the barcode.
• Symbol Size:
• Test Range:

 
IMPORTANT: Click File>Save Configuration when you are finished setting up your document.
 
Testing your settings
To test your settings go to Barcode>Recognize or OCRA>Recognize. This will read your document and
put the results in the greyed out text field under the document.  You can adjust your settings to increase
the accuracy of your reads.
 



 

 

PST CAR LAR Plug-In v1.0
 
The CAR LAR Plug-In will read the Courtesy Amount  ( the numeric amount) and the Legal Amount ( the
handwritten amount) off of the check. This will save the user from keying in all the amounts for checks
that have not had the amount encoded on them.  You can set a confidence threshold to allow only reads
with an acceptable confidence level  to be saved.
 
The CAR LAR Plug-In is typically run from the 'After an item has been saved' Insert Point or from the
Toolbar.
 
This Plug-In requires an additional hardware key to enable it. It will typically look like a usb thumb drive,
but older keys are made to go on the parallel (printer) port.

Simply plug it into the usb or parallel port of your computer. You can stack it on top of the EZ-Scan key, if
you are using a parallel port key to enable EZ-Scan.
 
Here are the options for the CAR LAR Plug-In.
 

 



 

 

PST Check Recognition Plug-In v1.0
 
The Check Recognition Plug-In can read the Courtesy Amount, Legal Amount, Name,Address, Date, and
check for a signature on a check.
 
It is typically run in the 'After an item has been Saved' Insert Point or from the Toolbar.
 
You will need to install the A2ia software
 

• Install A2iA software. It can be downloaded here:  http://www.pstinc.com/pub/
A2iA.CheckReader.4.4.2.build.35715.International.exe  

• Look for the latest A2ia release here http://www.pstinc.com/pub .
• Save the file to your hard drive and double click it to install the software. Accept all default values

during installation.
• NOTE: You must be logged in as an administrator to perform the installation.
• An A2iA license key will be required to run the plug-in.
• This is a USB dongle key. The key is similar in appearance to USB thumb drives.  Simply insert it

into an available USB ports on your PC before running the software.

 
Configure A2iA plug-in services

• The A2iA Plug-in requires a hardware dongle. IMPORTANT: The dongle must be installed before
the PC is powered on and the PC should be shut down before removing the key. DO NOT
remove the dongle when the PC is powered on.

• After installation of the software, you will need to start the A2iA service. Go to Start>My
Computer. Right click on My Computer and choose Manage. This will open the Computer
management console.

•  

http://www.pstinc.com/pub/A2iA.CheckReader.4.4.2.build.35715.International.exe
http://www.pstinc.com/pub/A2iA.CheckReader.4.4.2.build.35715.International.exe
http://www.pstinc.com/pub


 

 

• Double click on A2iA Protection Server International.

 



 

 

• Change Startup type to Automatic
• Click the Start button to start the service.

 
 
Workstation Setup

• The PC that the USB license key is physically attached to can be utilized as a server for all of the
workstations on your network.  

• Go to Tools>Options>Plug-ins-Plug-in Manager
• Click Scan>Just After an item has been saved
• Highlight the PST Check Recognition Plug-in.
• Click configure to set the settings for this plug-in.

 



 

 

 
Click the ‘Advanced’ button
 

 
 
All of the settings will be pre-filled. The only setting that will need to be changed is the Server Address. If
the key is being used only on one workstation ( and on the machine that it is physically installed on as a
server)  the address should be 127.0.0.1. If the key is being used to serve the license to other machines
on the network, the other workstations need to put the name or IP address of the server machine. Ex. \
\servername  or 192.168.0.1
 



 

 

PST Data Entry Plug-In v1.0
 
The Data Entry Plug-In will allow data entry while scanning. It fields are dynamic and based on the field
properties set up on the Verify tab of the options screen. You can set which fields are visible and which
ones are required.
 
It is typically run from the 'After an Item has been Saved' Insert point.
 
Here are the options for the Data Entry Plug-In.
 

 
Here is the Data Entry interface. It works just like the Data Verification system within EZ-Scan.
 

 
The splitter bar in the center of the form can be adjusted to increase the image size in proportion to the
data entry fields. You can also click on the center of the splitter to hide or show the image.



 

 

PST Data Validation Plug-In v1.0
 
The PST Validation Plug-In  will retrieve items from the database that have potentially corrupt data. The
Data Validation tool can only test for missing data. Required fields that have invalid data needs to be
corrected also. These queries will help you identify invalid data. It will fill the grid with the results from
each query.
 

 
It will query the database for the following:
 
Account numbers that contain the Check numbers
Account numbers that Match the Check numbers
Account numbers that aren't in the lookup table
Amounts that are greater than...
Amounts that are less than...
Check numbers that contain the Account number
Check numbers that are greater than...
Check numbers that are less than...
Check numbers that are duplicated
Route + Account + Check numbers that are duplicated
Route codes that are not in the lookup table
 
 
If you want to use a date range, you can enter a date or dates to validate.



 

 

PST Document Recognition Plug-In v1.0
 
The Document Recognition Plug-In can determine based on MICR content whether a document is a
check or a coupon. It will automatically update the doc type field in the EZ-Scan database and group
items using the Group ID.
 
Note: When using this plug-in you must sort your documents in the order of coupon then checks. The
change from a check to a coupon will signal the software to start a new Group ID. You can have multiple
coupons or checks in one group. Just make sure to sort then with all of the coupons first, then all of the
checks.  ex. coupon, coupon, check or coupon, check, check or coupon,coupon,check, check.
 
It is typically run from the 'When data is received' Insert Point.
 
Here are the options for the Document  Recognition Plug-In.
 

 
Valid MICR Percent
This will set a minimum percentage of Valid MICR characters that must present to identify an item as a
check. It defaults to 50.
 
Min MICR Chars
This will set a minimum number of MICR characters present to identify an item as a check.
 
The default values for both Valid MICR percent and Min MICR chars will not need to be changed in most
situations.
Update Coupons with Check Data
This will update the coupon record with data taken of the check. It will update the Account, Route
Code, Tran Code, Check Number and Amount (if the amount is encoded) fields of the Coupon from the
corresponding group.



 

 

 
Note: If there is a Customer Account Field needed for the coupon, be sure to create another field to store
that data in. When using the 'Update Coupons with Check Data' feature, if you use the Account field for
the customer account, the account number from the check MICR will overwrite it.
 
Document Masks
A mask can be used to determine document type. Check the 'Enable Document Masks' checkbox and
click on the 'Edit Masks' button.
 
Mask characters:
# numeric
? letters only
 

 
Group Starting document
The plug-in will group documents together based on a starting document type. For example, when you
set the starting document to '20 - coupon', each time that a doc type of 20 is scanned a new group will be
started and all documents following that coupon will be added to that group.
 
Mode
The document recognition plug-in can run in multiple modes which enforce document order.

1. Any - any combination of document types can run in any order. Each time a starting document
type is scanned a new group will be created.

2. Check only - all documents scanned will be identified as a 'check  (50)' doc type.
3. Coupon only - all documents scanned will be identified as a 'coupon (20)' doc type.
4. Many to many - any number of document types can be contained in each group. For example

 1 coupon with 2 checks, 2 coupons and 1 check, 1 coupon with 20 checks, etc
5. One to one - each group must contain one check and one coupon. Each time a starting

document type is scanned a new group will be created. The document order will be enforced
and the user will be alerted if the order is broken.

6. Page only - all documents scanned will be identified as a 'page(10)' doc type.

 



 

 

Prompt for Only Modes
This mode will allow the user to scan to override  the current mode and allow the user to scan one doc
type only for the current batch.
 

 
Create Batch Type Field
Check this option to create a 'Batch Type' field. This will add a batch field to the 'Batch Properties' screen
when scanning. This will allow the user to change the Document Recognition plug-in's 'Mode' with each
batch.
 



 

 

PST Image Validation Plug-In v1.0
 
The image QC Plug-In allows you to validate the image quality of item in EZ-Scan. It updates a field called
imgStatus in the EZ-Scan database based on the action taken in the Image QC. The item can be marked
as 'Good', 'Bad', 'Blank' and the image can be rotated 180 degrees.
 

 
To tag the items click the apropriate button or click the right mouse on each item and its status will toggle
between 'Good', 'Blank' and 'Bad' status. To move to the next set of images, click 'Next' or hit the 'N' key.n



 

 

PST MICR OCR Plug-In v1.0
 
The MICR OCR Plug-In will read the MICR line on a check using an Optical Character Recognition
engine. This allows you to use any scanner to read checks, even if it doesn't have a MICR reader.
It can also be used to verify or correct the MICR data read by the MICR reader on a check scanner.
 
 
Here are the options for the PST MICR OCR Plug-In v1.0
 

 
Use OCR to repair MICR
will replace misread characters from the MICR that was read by the check scanner with characters read
by the OCR engine.
For example if the scanner read 12?4 and the OCR engine read 1234, then the repaired MICR will be
1234.
 
Use OCR to validate MICR
will compare the characters read by the check scanner with the MICR read by the OCR engine. The only
characters returned will be the ones read the same by both methods.
For example if the scanner read 1234  and OCR read 12?4 then the MICR  saved would be 12?4.
 
Parse OCR to repair MICR
is the same as the repair option above except the fields are parsed before the repair
 
Parse OCR to validate MICR
is the same as the validate option above except the fields are parsed before the validation occurs.
 
Recognition - Min Confidence
The OCR engine returns a confidence value of the read. You can set the minimum confidence that will be
accepted. Value can be 1 to 5.
 
Detect Rotated Documents
This option will look for MICR on the bottom first and then the top of the document. This will read MICR
on items run upside down.
 



 

 

Apply changes to these fields
Uncheck the fields that you don't want to update with this Plug-In.



 

 

PST OCR Mitek Plug-In v1.0
 
The OCR Mitek Plug-In is an OCR Reader that can be customized to read any number of custom zones
on a document.
 
It is typically run from the 'After an item has been Saved' Insert Point, but can also be run from the Plug-in
button on the toolbar.
 
This Plug-In requires an additional hardware key to enable it.  PST will supply the key when you purchase
the software. The key will be a usb key that resembles a thumb drive. Simply plug the key into the usb
port.
 
To configure the PST OCR Mitek Plug-in go to Tools>Plug-Ins>Plug-in Manager  from the main toolbar.
Click on Plug-ins in the left panel. Click on PST OCR Mitek Plug-In v1.0 in the right panel to select it.
Then click the 'Configure' button.
 
For more information on the PST OCR Mitek Plug-In v1.0  See the PSTOCR.chm which by default is
installed to C:\EZ-Scan\Help\pstOCR.chm and is also located at C:\Windows\Help\PSTOCR.chm
 
It is also available on the web at http://www.ez-scan.net/webhelp/pstOCRMtk/
 

http://www.ez-scan.net/webhelp/pstOCRMtk/


 

 

PST Parsing Plug-In v1.0
 
The PST Parsing Plug-In  can be used to parse a field in EZ-Scan that contains multiple field values. For
instance you could use an OCR reader to fill the MICROCR field of the EZ-Scan database. This field can
contain multiple fields that need to be parsed and stored in separate fields.
 
The options screen is used to set up the plug-in.
 

 
Field To Parse
This is the field that will be parsed into separate fields.
 
Doc Types to Parse
You can choose to include any or all document types to parse. For instance you may want to parse the
MICROCR field for coupons but not for checks. Choose multiple lines by Ctl + clicking.
 
Retain data between valid doc types
When checked this will update the data parsed in all non parsed documents. This could update the
CustAccount field on checks for instance when the CustAccount field is parsed from data on a coupon.
 
Data To Parse
Once you have selected a field to parse from the list of available fields you can click the ellipsis button
next to this text box to retrieve the value contained in this field from the current item in the grid or the last
item that was scanned if there are no items in the grid. You can optionally type a sample data line here.
 



 

 

Line Length
Click the ellipsis button next to this text box to fill it with the length of the line in the Data to Parse text
box. This will enforce the length of the data before  parsing. A value of 0 means the length will not be
enforced. If the length of the field to be parsed does not match the length specified then the parsing plug-
in will not parse the data. If for instance the length of the field to be parsed should be 20 characters and
it missing 1 character, all the parsed fields would be incorrect because the parsing plug-in works on fixed
character positions and lengths.
 
Add Fields
To define how the Field to be parsed is parsed, you use the grid and text boxes in the bottom section of
the screen. Select the first field to be parsed from the dropdown list. Then enter  the position of the first
character of this field and the length of this field.  You can also highlight the field in the Data To Parse
text box and the field position and length will be filled in for you. Click the 'Add' button and the field will be
added to the grid. Repeat this for all the fields to be parsed. DO NOT INCLUDE DELIMITERS IN YOUR
FIELD POSITIONS.
 
Format
Some fields such as amounts or dates need to be formatted. Amounts are usually printed  in OCR lines
without decimals, so the field will need to be divided by 100 before being added to the database. Choose
Div/100 in this case for the format. If the field is a date field you will need to choose the format that the
date data appears in the Field to Parse from the dropdown so that it can be properly converted to a date
value before being stored in the database. ex. mmddyyyy would be chosen for  a value of 03012006 in
the Field to be parsed and  would be stored in the database as 03/01/2006
 
Testing
Once you have defined all of your fields, you can test the parsing plug-in to make sure all of the data is
parsed properly. Click the test button and you will be presented with the data parsed into the separate
fields. Adjust any settings as necessary and test again until all fields are parsed properly.
 
 

 
Insert Points
The PST Parsing Plug-In would typically be run from the 'Just after an item has been saved' Insert point.
 



 

 

PST PDF Out Plug-In v1.0
 
The PDF Out Plug-In allows you to output items scanned in EZ-Scan in PDF format.
Options
To get to the option screen, highlight the PST PDF Out Plug-In in the Plug-In Mgr and click configure.
PST PDF Out Plug-In does not appear in your list of available plug-ins see Installing components.
 

Output To
You have 3 choices for output
Email
If you select Email all items all items in the grid will be compiled into a single PDF document and attached
to an email using your default email program.
 



 

 

Single file
If you select Single File, all items in the grid will be compiled into a single PDF document. The user will be
prompted to name and save the document to the hard drive. You can optionally check the 'Display PDF'
check box to display the PDF document when complete.
 
Multiple files
If you select Multiple Files, a PDF document will be created for each item in the grid. The PDF documents
will be created in the directory specified in the Path text box. If no path is specified the items will be
created in the same directory as the EZ-Scan images for that batch. The directory structure used by EZ-
Scan is as follows:
{Image Directory specified in Storage locations} \ {Company ID (PST by default} \ {Process Date} \ {Batch
ID} \
You can specify a naming convention to use for the items  created. Click the ellipsis button next to the
Naming Convention text box to get a list of available fields to add to the naming convention.
 



 

 

 
As you click on a field from the list of available fields a macro representing that field will be added to the
Naming text box a the current cursor position. After adding fields you can edit the text in the naming text
box with literal characters such as "-" or "." to divide fields. The above example will create files named like
this:
 

account no          check no

• 123456789-0123.pdf
• 837521723-8394.pdf
• 773332882-.0043.pdf

 
To duplicate EZ-Scan's standard naming conventions use {ItemNo}{DocType}.pdf as your naming
convention.
 
Insert Points
The PST PDF Out Plug-In can be run from

• The toolbar (the plug-in will be run against all item in the grid)
• The 'Just after an item has been saved' Insert point in both Scanning and Verify (If run from

either of these insert points the PDF  out will only save to multiple files and will use the EZ-
Scan image directory and standard naming convention (ItemNoDocType.pdf) it neither one is
specified in the options. If a path an/or naming convention is specified they will be used.

• The Export menu. This plug-in can also be used as an export. All options are available when
used as an export.

 
Scan to PDF
To create a PDF for each item scanned (while scanning) do the following:



 

 

• Load the plug-in in the 'Just after an item has been saved' Insert Point under the Scanning
section

 
This will save a PDF file for each document scanned in the same folder as the EZ-Scan image created
using the same naming convention as EZ-Scan, unless a different path or naming convention is specified
in the options screen.
 

 
Here are examples of the .tif and  the .pdf files for item number 1 in the batch above.
 



 

 

 



 

 



 

 

PST Sorting Plug-In v1.0
 
The PST Sorting Plug-In can sort items based on the data contained in the MICR line of that item.
 
Configuring the PST Sorting Plug-In
To configure the plug-in:

• Go to Tools>Plug-Ins>Plug-In Manager
• Select PST Sorting Plug-In in the right pane.
• Click the 'Configure' button.
• The following screen will appear.
• Enter the criteria used  to sort items in the grid.
• Add a wildcard '*' character to sort items based on a range of values.

 
In the preceding example, the following will happen:

• Items with a route code starting with 123 will go to pocket 1 ex. 123456789,
123444444,123555666

• Items with a route code starting with 456 will got to pocket 2 ex. 456777888,456999222,
456111111

• Items with the exact route code 12345678 will go to pocket 3
• Items with an account number starting with 123 will go to pocket 4
• Items with an account number starting with 456 will go to pocket 5
• Items with an exact account number of 123456789 will go to pocket 6
• Items that match none of the above  criteria will go to pocket 7
• Items that are misread are sent to pocket 8. (If the MICR is not read properly, a decision cannot

be made for  which pocket it should go in)

 
Insert Points
The PST Sorting Plug-in can  only run in the 'When data is received' Insert Point.
 
To install the plug-in:
Click on the Scan>When data is received  Insert Point.
Click the 'Add' button and select the PST Sorting Plug-In from the drop down list that appears.
 



 

 

 
 
The insert point will text will bold when a plug-in has been installed to visually show you where plug-ins
have been installed.
 



 

 

PST Verify Template Plug-In v1.0
 
The Verify Template is used to set up different verify properties quickly without having to edit each fields
required property. Sometimes a set of documents will have a different set of required fields.
 
Create a template:
Go to the Plug-In manager, select the PST Verify Template Plug-In and click Configure. A defaul template
will be created the first time that you open the configuration screen.
 
On this screen you simply modify the settings for showing each field on the verify screen and the required
property which enforces valid data in each field before saving a record.
 

 
You can modify the Default template as needed.
 
Create a new template
Click the add button to create a new template
 

 
Enter the name for your new template and click 'OK'
 
The Verify Template plug-in is typically run from the following Insert Point:
 



 

 

Verify
Before the verify process begins
 

When you start the verify process you will be asked to choose the Verify template to use.
 

 
This will allow you to have a different set of required properties for different batches of items.

 
 



 

 

PST Virtual Encoder Plug-In v1.0
 
The Virtual Encoder is a Plug-in that will virtually encode the amount on a check image. This is a useful
plug-in for scanner/encoders that have cameras located before the encoder in the transport such as the
Fuji Systems Machine FZ 5180. Since the camera is located before the encoder the image does not
match the physical check after encoding.
 
There are a few options to set for the Virtual Encoder Plug-In
 

 
Encoding
Encode all items will do just that. Encode blank items will check to see if the image already contains the
amount encoded on it and only encode items that have not yet been encoded. You can also choose to
prompt the user when a check already has the amount encoded and let the user decide whether it should
be re-encoded or not.
 
Recognition
The minimum confidence property here is used to by the OCR engine that verifies the existence of
encoding currently on the check. Valid values are 1 - 4. Default value is 3.
 
Here is an example of a check before the virtual encoder is run.
 
Here is the check image after virtual encoding.
 
This plug-in can be run from the following insert points:
 
Scan

Just after an item has been saved
Before the next batch
 

Verify
Before the verify process begins
As each verify record is loaded
When a item is about to be saved
Just after an item has been saved
When all items have been verified
 

This plug-in can also be run from the Plug-Ins menu. When run from the menu the plug-in will run on all
the items currently in the grid. Do a search for the items that you would like to encode, and then run the
plug-in from the menu or from the toolbar.

 



 

 

PST Voice Verify Plug-In v1.0
 
The Voice verify Plug-In is a program that will read a field from the items in the grid for you. Typically,
as a verification process, 2 processors will verify the physical documents against the items in the grid.
One person will read the amounts off the checks from the grid, while the other thumbs through the stack
of checks, making sure that no checks are missing from the grid. With Voice Verify one person can do
this. The program will read the amounts from each item in the grid as one person can thumb through the
checks. It can be stopped at any point by hitting the enter key if an item is missing. It will continue from
that last item if restarted.
 
The Voice Verify Plug-In is typically run from the Toolbar.
 
Here are the options that you can set for the Voice Verify Plug-In.
 

 



 

 

 



 

 

Printing Items
 
You can print images in the grid by clicking the Print icon on the Toolbar or File>Print or Ctl + P.
This will give you the Print Dialog box. The 'Output To' dialog box will contain all the printers installed on
your computer and the EZ-Scan PDF printer.
 

 
The print options we chose would produce a full-size page like this:
 



 

 

 
In the Output To drop down box you can choose EZ-Scan PDF Printer. This will print to a pdf file on your
hard drive. When you click 'OK' a 'Browse' dialog box will be presented to allow you to save the file with the
name and location of your choice. The finished output can be viewed with Adobe Acrobat and will look like
this.
 



 

 



 

 

 



 

 

Batch Detail Report
 
Click Reports>Batch Detail Report from the main menu.
 

 
Enter the Batch and Date information in the text boxes. You can enter a range of batches, or a range of
dates or both.
 
Configure Detail Report
Click the configure button to get to the Settings screen.
 

 
Report Header: Just type your header text in the box.
 
Doc types: Select the doc types that you would like to include in your report. Ctrl click to select multiple
doc types.
 
Show Company ID: Check this to add company ID criteria to the confirmation screen.



 

 

 
Click 'OK'  on the confirm screen to run your report.
 
Here is an example of the Batch Detail Report.
 
Saving Report to Word, Excel or HTML format
Select the format that you would like to save the report in from the Save As / Email Format drop down
box. Click the Save button to save it to disk.
 
Email the report
Select the format that you would like to save the report in from the Save As / Email Format drop down
box. Click the Email Button. This will create a new email with the default email system on your computer,
with the report as an attachment.
 
Printing the Report
Click the Print button to print the report.
 
Zoom In / Out
Left clicking on the report will zoom in. Right clicking will zoom out. You can also select zoom level from
the drop down box.
 
Navigation of report pages
Click the arrow buttons to navigate through the pages of the report. The number of pages will be
displayed between the arrows.



 

 

Batch Detail Report Sample



 

 

Batch Listing Report
 
Click Reports>Batch Listing Report from the main menu.
 

 
Enter the Batch and Date information in the text boxes. You can enter a range of batches, or a range of
dates or both.
 
Configure Listing Report
Click the configure button to get to the Settings screen.
 

 

• Report Header: This is text that will appear at the top of the report
• Rows Per Column: Adjust the rows per column to adjust to your printers printable area



 

 

• Index Column: You can choose Item No. Check No. or ID. This will print along with the amount
for each Item

• Doc Types: Select the doc types that you would like to include in your report. Ctrl + click  or
Shift + click to multi select.

• Show Company ID: Checking this box will add the Company ID to the criteria on the confirm
screen.

 

Click 'OK' to run your report.
 
Here is an example of the Batch Listing Report.
 
Saving Report to Word, Excel or HTML format
Select the format that you would like to save the report in from the Save As / Email Format drop down
box. Click the Save button to save it to disk.
 
Email the report
Select the format that you would like to save the report in from the Save As / Email Format drop down
box. Click the Email Button. This will create a new email with the default email system on your computer,
with the report as an attachment.
 
Printing the Report
Click the Print button to print the report.
 
Zoom In / Out
Left clicking on the report will zoom in. Right clicking will zoom out. You can also select zoom level from
the drop down box.
 
Navigation of report pages
Click the arrow buttons to navigate through the pages of the report. The number of pages will be
displayed between the arrows.



 

 

Batch Listing Report Sample



 

 

Batch Summary Report
 
Click Reports>Batch Summary Report from the main menu.
 

 
Enter the Batch and Date information in the text boxes. You can enter a range of batches, or a range of
dates or both.
 
Configure Summary Report
Click the configure button to get to the Settings screen.
 

 

• Report Header: Type your header text in the box.
• Doc Types: Select the doc types that you would like to include in your report. Ctrl + click  or

Shift + click to multi select.
• Show Company ID: Checking this box will add the Company ID to the criteria on the confirm

screen.
•  



 

 

 
 Click 'OK' to run your report.
 
Here is an example of the Batch Summary  Report.
Saving Report to Word, Excel or HTML format
Select the format that you would like to save the report in from the Save As / Email Format drop down
box. Click the Save button to save it to disk.
 
Email the report
Select the format that you would like to save the report in from the Save As / Email Format drop down
box. Click the Email Button. This will create a new email with the default email system on your computer,
with the report as an attachment.
 
Printing the Report
Click the Print button to print the report.
 
Zoom In / Out
Left clicking on the report will zoom in. Right clicking will zoom out. You can also select zoom level from
the drop down box.
 
Navigation of report pages
Click the arrow buttons to navigate through the pages of the report. The number of pages will be
displayed between the arrows.



 

 

Batch Summary Report Sample



 

 

Grid Listing Report
 
The grid listing report will print a report which pulls its data from the data currently visible in the grid. You
can adjust what is printed by changing the look or content of the grid. You can use the 'Grid Settings'
dialog to make fields hide or show specific fields. You can adjust the with of the visible columns. You can
change the sort of the report by changing the sort of the grid. All these settings will be reflected in the
report. See 'Using the Grid' for details on customizing your grid.
 
Retrieve the items for your report using the 'Find' feature. Click Reports>Grid Listing Report.
 

 
You can choose to print the selected rows, or the entire grid. When you click the 'Configure' button you
get an options screen that will allow you to set the text for the header text.
 

 



 

 

Reports
 
The following reports are included with the EZ-Scan installation:
 
Batch Listing Report
Batch Summary Report
Batch Detail Report
Grid Listing Report
 
 Custom reports are available Contact PST for details.
 



 

 

Route Report
 
To be added.



 

 

 



 

 

Scanning Items
 
Preparing Documents
Align the bottom right edge of the documents that you are going to scan. A document Jogger is
recommended for this. The better the documents are aligned, the less likely they are to jam in the
scanner, or double feed.
 
Important: Make sure that documents have been checked for staples. Running staples through the
scanner can damage the unit.
Batch Information
Place the items you wish to scan in the feeder of the scanner and then click the Scan button to bring up
the Batch Properties dialog box.  Enter the Batch ID you would like to use. The Batch ID may consist of
any alphanumeric sequence that would uniquely identify the grouping of documents you intend to scan.
You are limited to legal file name characters, because the Batch ID will be used to name the directory that
the images are stored in.  The Process Date defaults to today’s date.  You can change it if necessary.
Click OK and the items will immediately begin scanning.
 

 
While scanning, items will be displayed on screen and added to the Grid in the order scanned.  Click on
the rows of the grid to display the corresponding image.  
Clearing Jams
If an item gets jammed in the scanner, click the 'Reset/Eject' button on the right side of the screen or the
'Eject' Icon on the Toolbar.
 



 

 

MICR Masks
 
The MICR line along the bottom edge of a check typically contains the following 3 fields:

• Route Code (ABA number)
• Bank Account number
• Check Number

 
It may also contain 3 additional fields:

• Amount
• Tran Code
• EPC

 
EZ-Scan has a very robust MICR parsing engine which separates these fields and saves them in the
appropriate field in the database. MICR layouts are not consistent and occasionally a check may contain
a MICR line that cannot be parsed properly using the parsing engine. EZ-Scan allows you to add a Mask
for MICR layouts that cannot be parsed by the engine. It allows you to define the location of the individual
field data within the MICR line and save that information so that when a check with a matching MICR
layout is scanned it can be parsed correctly.
 
Using the MICR layout editor

• Scan the check with a MICR layout that needs to have a MICR mask created.
• If the check is no longer available to scan again, then locate the check in question using the

find feature to get it in the grid.
• Right click on the item in question and choose Properties

 

• This will display the Item Properties dialog box. Locate the MICROCR field in the list
• Highlight the MICROCR value right click on it and choose Copy from the Pop-up Menu.



 

 

 

• Go to Tools>Scanner Setup and select the MICR tab of the options screen.

 



 

 

• Click the Edit Layouts button to bring up the MICR Layout Editor

 

• The MICR text box will be prefilled with the MICR from the check that you just scanned, if you
have  just  scanned one. If not then paste the MICR that you copied from the Item Properties
screen into the MICR text box by right clicking on it and choosing Paste from the Pop up menu.

• If there are any question marks in your MICR line you must replace the question mark with the
correct character from the check. If the scanner misreads a character it will put a question mark
in its place ("?") The MICR line must be corrected before testing.

• Click the Test button to test the Parsing engine on the MICR line. You will see a dialog box with
the individual field values parsed by the parsing engine.



 

 

 

• The MICR was not parsed properly so click the No button.
• You will then be prompted to add a Mask for this MICR  line. Click Yes.

 

• The Mask text box will enable and a mask of questions marks ("?") and special characters ("t"
"o" "a" "d" representing delimiting characters)  will be created.



 

 

 

• For each field in the MICR line, use your cursor to highlight the field in the mask (including
delimiters) , then click the button in the fields frame below corresponding the field that is
highlighted. This will place the positioning values in the start and length text boxes for the
corresponding field. It will also show the mask characters that represent the field in the mask in
the mask text box in the lower fields frame, and it will show the parsed value of the field in the
Values text box.



 

 

 

• Repeat this procedure for all fields in the MICR line and then click the Save button.



 

 

 

• Now click the Test button once again to make sure that your new mask works.

 
Click Yes if it is parsed correctly and the mask is complete. Now each time a MICR line matching this
layout is scanned in EZ-Scan it will be parsed properly.



 

 

 
Eventually the parsing  engine will be nearly 100% accurate, once you enter the necessary masks for
your items.



 

 

 



 

 

Toolbar
 
The toolbar has buttons for the most common features of EZ-Scan.
 



 

 

 



 

 

 



 

 

Eview21  Check 21 x9.37
 
The Eview21 check 21 x9.37 viewer is included with EZ-Scan and can be found in the C:\EZ-Scan\Tools
directory.
 

 
Double click the file to launch the viewer.
 
Select File>Open to browse to the x9.37 that you would like to open.



 

 

n
 
 
The file will load into the viewer with a tree view hierarchy of the records in the file on the left, a grid showing
the data corresponding to the currently selected row, a grid below that showing data from the records below
the current selection,  and an image window.
 



 

 

 
The file hierarchy is organized in the following way:

• File header

• Cash letter header

• Batch header

• Detail records
• Batch footer

• Cash letter control
• File header control

 
Click on an item to see the image and data corresponding to that row.



 

 

 
Data can be copied from the grid to be pasted into Excel.



 

 

 
Records can be selected and then right click on the selected records. A copy menu will be presented. Click
copy from the popup menu and then open Excel. Click the paste button in Excel to paste the data from the
Eview21 application.
 



 

 

 
Wells Fargo formatted files: Files with an extension of .wff will be treated as Wells Fargo formatted files. You
will need to rename Wells Fargo Files to .wff extension to open in EView21 in Wells Fargo format. Any other
extension is valid, but will be opened in standard x9.37 format.



 

 

PST Database Viewer
 
The pst Database Viewer will allow you to open Microsoft Access databases without having Access
installed on your computer. This tool can come in handy if you need to open your EZ-Scan database.
 
Warning: This is an advanced tool and should only be used by administrators. PST cannot be responsible
for any loss of data when using the database viewer. Contact PST for help with this tool.
 



 

 

PST Image Viewer
 
The PST Image Viewer is stand alone image viewer that supports all image formats that are created by
EZ-Scan.

• Tiff
• Tiff Multipage
• Jpeg
• Jpeg Multipage
• Tiff Glued
• Jpeg Glued

 
Some formats such are Jpeg multipage are not supported by some image viewers. The PST image
viewer will open them.
 

 
Send images to EZ-Scan



 

 

Images can be imported into your EZ-Scan database from the image viewer. Choose File>Send To EZ-
Scan from the main menu. You will be asked to provide Batch Information to add the image to.
 



 

 

Activation Tool
 
The Activation too can be used to remotely update the license information on your PST license key
(dongle).
Your PST license key must be attached to the machine to activate a product.
 
NOTE: You will need internet access to use the Activation Tool.
 
Go to Help>Activation Tool to launch the Activation Tool.
 

 
Contact PST to purchase new products and provide them with your serial number. The serial number is
the 3rd text box in the product code.
In this case it is 2109389981. Once you have purchased your new product, it is a simple process to
activate the license for it.
 

• Click the 'Update' button to load the newest set of products into the 'Product to activate' drop
down list.

• Select the product to activate from the list.
• Click the 'Activate' button.
• You will receive a confirmation message in the status bar of the Activation Tool.
• If the product cannot be activated or if an error occurs a message will be shown in the status

bar also. Contact PST in the case of an error.

 
If you do not have a valid license for EZ-Scan you will see DEMO in the EZ-Scan title bar. Once your
license is activated the DEMO caption will no longer appear and the software will be out of Demo mode.



 

 

Compact The Database
 
Select Tools -> Compact Database from the menu.
 

 
Compacting your database should done on a regular basis. This will reduce the database in size and
increase the efficiency of the database.
 
We recommend that you compact your database on a weekly basis.
 
This utility can take a while if you haven't used it in a long time.
 
 



 

 

Image Relocator
 
The image relocator tool can be used to relocate images stored in the database to files, or to copy
images stored in files into the database.  I f relocating to the database you also have the option of
deleting the image files that were copied to the database.
 
Go to Tools>Image Relocator
 
You will see the following screen

 
Choose where to relocate the images.  You have a choice to relocate images based on a date range or
using the items in the grid. Using the items in the grid gives you the flexibility of using the Find feature to
locate the images to relocate.
 
Click 'OK' to begin the relocation.
 

 



 

 



 

 

Purge Data
 
Select Tools -> Purge Data from the menu.
 
Select the date or date range of the items that you would like to delete. You can choose to delete the
images associated with these records by checking the check box.
 
Optionally you can choose to delete specific document types by selecting the doc types in the list box.
 
THIS CANNOT BE UNDONE. Do not do this unless you are sure that you no longer need this data.



 

 

Query Tool
 
To be added.



 

 

Storage Wizard
 
The Storage Wizard will help you create off line image volumes.
 
Before you run the Storage Wizard, you must create a Storage Location for your CD or DVD drive that
you will be archiving your images to. Go to Tools>Options from the main EZ-Scan menu. Click the
Storage tab.
 
Typically you will have one storage location. This is the main location of the images for your database.
You will need to add a second storage location which points to the location of your off line volumes. This
is typically the CD or DVD drive on your computer. This could also be a CD or DVD jukebox.
 
To add a new storage location, click the 'Add' button.
Choose your drive from the list or type in the address. Make sure to give it a description that will help you
to identify it easily. If you chose a CD, or DVD jukebox, you may need to choose push down  from the
device type drop down. Typically you will choose Standard. Push down will repeat the volume name in
the path and is typically needed for jukeboxes.
 
Now that you have your storage devices complete you can start the Storage Wizard.
 
Select Tools -> Storage Wizard from the main menu.
 
 
You have 3 options

• Create a new storage volume
• Delete images from the original location
• Manage and existing volume

 
Create New Storage Volume
This archives images to an off line volume. The data for the images will still be contained in the main
database, so that items can be retrieved easily. If an off line image is requested, the software will prompt
the user to insert the volume that it has been moved to. You can also retrieve images directly from the
CD. Just open the database located on the CD with the File>Open Database from EZ-Scan's main menu.
You can then search and retrieve items directly from the CD.
 
Delete images from the original location
When creating a volume the images are moved to a temporary directory on your hard drive. You will then
burn the volume to a CD. Make sure that the CD has been made properly, and images can be retrieved.
At this point you can then delete the images from the original location.
 
Manage an existing volume
This will allow you to move images back to there original location or to another storage location.
 
Volume Creation Criteria
 



 

 

You can choose to automatically create the volume starting from oldest to newest or specify criteria to
retrieve data for your volume by company name and date range. Date range will use the process date
stored with each batch.
 
Volume Size
You can choose CD, DVD or enter a custom size for the volume that you are going to create.
 
Choose the volume size from the drop down menu and click Next.
 
Select Storage Location
This will be the removable media storage location that was created at the beginning of this page.
 
Choose Volume Name
Give your new volume and name and description. Make sure to give a meaningful name to your volume,
such as date + Company or something that will help describe its contents. A list of existing volumes is
given just as a reference. Your volume name must be unique.
 
Temporary directory
 
If the storage location that you have chosen for your new volume cannot be written to directly, you will
have to write your volume to a temporary directory. This will be the case for CD or DVD, or Jukebox
drives.
 
Choose a location to create the temporary volume. Free space and Volume space needed are displayed
for the location that you have chosen. Make sure there is enough available disk space for your volume.
 
You will burn this directory in its entirety to your CD or DVD when the storage wizard is complete.
 
Storage Summary
You will be presented with a summary screen before starting the archiving process. Make sure that all the
information is correct and click next to begin the process.
 
Process Progress
The progress and logging will be displayed as the process runs.
 
Complete
When the process complete you can click on the 'View Report' button. This will give a detailed report
of the archiving process. It is not necessary to print the report if you don't need it. It can be a useful
troubleshooting tool if there are errors.
 
Burn Volume to Removable media
If you chose a CD or DVD drive for your storage location, you will now need to burn the newly created
volume to the CD or DVD.
 
Using CD creation software burn the entire folder that was created in the temporary directory with the
name of your volume to the CD or DVD. Make sure to name the volume with the same name as the
folder. This is very important. The name of the volume that you create will be used by EZ-Scan to identify
the volume that you need to retrieve an archived image.
 



 

 

Test the volume
Test the volume and the archiving process by doing a search in EZ-Scan that will retrieve and image from
that volume. When you click on a record that has been archived, you should get a message from EZ-
Scan directing you to insert the correct volume to retrieve the image.
 
Insert the volume to retrieve the image.
 
Repeat this a number of times to ensure that images can be retrieved. Once you are confident that the
volume is good, you will need to delete the images from their original location.
 
Delete Images from original location
Start the Storage wizard again. Choose Delete images from the original storage location.
 
Choose Volume to Delete
 
Choose the volume from the drop down list of available volumes. When you click the 'Next' button the
images will be deleted from the original location.
 
IMPORTANT: Make sure this is what you want before clicking 'Next'. This cannot be undone.
 
Managing Volumes
Open the Storage Wizard and choose 'Manage Existing Volumes' from the first screen and click 'Next'.
 
Choose the volume from the list that you would like to manage.
You have 2 choices

• Relocate Volume ( Move all items from one storage location to another. This is only useful if
you have more than 2 storage locations. Most will not.)

• Return Volume to original location ( This will move the volume back to the original location.
Don't do this if you already deleted your images from the original location)

 
Make your choice and click next.



 

 

 



 

 

The Data Grid
 
Overview
Data is presented in a grid located on the bottom half of the main screen of EZ-Scan. Each row of the grid
represents one item in the database. Each column represents one data field stored in the database for that
item. Each row is referred to as a record. Each column can be referred to as a field.
 

 
Column Positions
You can re-arrange the order of the columns in the grid. Click in the center of the column header and drag
the column to the location desired. EZ-Scan will remember the order of the grid fields for you next time you
run the program.
Column Widths
You can adjust the column widths by placing your cursor between two columns. Your cursor will turn to a
double bar with arrows on each side. Hold down the left button of the mouse and drag to make the column
larger or smaller. EZ-Scan will remember all column widths for you next time you run the program.
Sorting
You can sort on any columns by double-clicking on the header. The sort direction will reverse each time
that you click on the header. First click will be ascending, next click will be descending. If you have a large
amount of data in the grid it may take a few seconds to sort.
Editing
Double clicking on a record will open that item for editing.



 

 

Edit the item and click 'Save' to save your changes. The 'Enter' key will also click the 'Save' button.
Multi selecting items

You can select multiple items in the grid just as you would in Windows Explorer.
Hold the CTRL key while clicking to select non adjacent items.
To select a range of items select the first item. Scroll to the last item that you would like to select. While
holding the SHIFT key click on the last item and all item between will also be selected.



 

 

To select all Click the square in the top left corner of the grid.
Right Click menu
Right click on the grid header  to get the following menu.

 
Grid Settings
This menu item will only be visible if you right click in the grid header.

Grid Font
You can change the font used in the grid using the ellipsis button next to the font text box.
Visible Grid Fields
You can customize the way the grid presents data on this screen. The grid on this screen presents you with
all available fields from the EZ-Scan database. The checkbox on the right will allow you to show or hide the
field in the main grid.
Grid color controls



 

 

Click on the color tab to get access to the color controls.

Click on the ellipsis next to each text box to set the color of the even and odd rows of the grid.
Restore default grid settings
You can change all grid settings back to the default settings by clicking the 'Default' button.
Edit Item
This will open the record for editing just as double clicking does, which was explained above.
Print
This will open the Print dialog box. See Printing Items for details.
Find
This will open the Find dialog box. See Locating Items for details.
Delete
This will delete all selected items in the grid. Hitting the 'Delete' key on your keyboard will do the same.
Select All
This will select all items in the grid. You can also hit CTRL + A or click the square in the top left corner of
the grid to do the same.
Total
You can get a total of items in the same batch, of the currently selected items, or all the items in the grid.
The total will be displayed in the status bar near the bottom right of the grid.
Find items from the same
This allows you to filter the items in the grid by Batch, Process Date, Company, or Group. The group option
only appears if you have 'Allow Grouping of items' turned on. Once the grid is filtered, you will also have
the option to 'Revert to last query'. This will remove the filter and show you all the items that were in the
grid before the filter was applied.
 
Properties
This will display all the data in the database for  the current item in the grid.



 

 

 



 

 

 
Copying data and images to other applications
You can copy the selected data  to the clipboard and paste it into many other applications such as

• Microsoft Word
• Microsoft Excel
• Microsoft Wordpad

To copy data in the grid select the items that you would like to copy and choose Edit>Copy or CTRL +C.

Choose Copy Data to the Clipboard from the Copy Dialog.
Then switch to the application to paste the data into and choose Edit>Paste or CTRL + V. This will paste
the data to the other application.
 
Excel Example



 

 

 
Word Example

 



 

 

You can also copy the image and paste it into many image editing applications such as

• Adobe Photoshop
• Microsoft Paint
• Microsoft Photo Editor
• Microsoft Word

 
To copy the current image in the grid  choose Edit>Copy or CTRL +C.

Choose Copy Image from the copy Dialog.
Switch to the application that you would like to copy the image to and choose Edit>Paste or CTRL + V
 
Word Example with image and data  pasted in the document

 
Paint Example



 

 



 

 

The Data Grid
 
Overview
Data is presented in a grid located on the bottom half of the main screen of EZ-Scan. Each row of the grid
represents one item in the database. Each column represents one data field stored in the database for that
item. Each row is referred to as a record. Each column can be referred to as a field.
 

 
Column Positions
You can re-arrange the order of the columns in the grid. Click in the center of the column header and drag
the column to the location desired. EZ-Scan will remember the order of the grid fields for you next time you
run the program.
Column Widths
You can adjust the column widths by placing your cursor between two columns. Your cursor will turn to a
double bar with arrows on each side. Hold down the left button of the mouse and drag to make the column
larger or smaller. EZ-Scan will remember all column widths for you next time you run the program.
Sorting
You can sort on any columns by double-clicking on the header. The sort direction will reverse each time
that you click on the header. First click will be ascending, next click will be descending. If you have a large
amount of data in the grid it may take a few seconds to sort.
Editing
Double clicking on a record will open that item for editing.



 

 

Edit the item and click 'Save' to save your changes. The 'Enter' key will also click the 'Save' button.
Multi selecting items

You can select multiple items in the grid just as you would in Windows Explorer.
Hold the CTRL key while clicking to select non adjacent items.
To select a range of items select the first item. Scroll to the last item that you would like to select. While
holding the SHIFT key click on the last item and all item between will also be selected.



 

 

To select all Click the square in the top left corner of the grid.
Right Click menu
Right click on the grid header  to get the following menu.

 
Grid Settings
This menu item will only be visible if you right click in the grid header.

Grid Font
You can change the font used in the grid using the ellipsis button next to the font text box.
Visible Grid Fields
You can customize the way the grid presents data on this screen. The grid on this screen presents you with
all available fields from the EZ-Scan database. The checkbox on the right will allow you to show or hide the
field in the main grid.
Grid color controls



 

 

Click on the color tab to get access to the color controls.

Click on the ellipsis next to each text box to set the color of the even and odd rows of the grid.
Restore default grid settings
You can change all grid settings back to the default settings by clicking the 'Default' button.
Edit Item
This will open the record for editing just as double clicking does, which was explained above.
Print
This will open the Print dialog box. See Printing Items for details.
Find
This will open the Find dialog box. See Locating Items for details.
Delete
This will delete all selected items in the grid. Hitting the 'Delete' key on your keyboard will do the same.
Select All
This will select all items in the grid. You can also hit CTRL + A or click the square in the top left corner of
the grid to do the same.
Total
You can get a total of items in the same batch, of the currently selected items, or all the items in the grid.
The total will be displayed in the status bar near the bottom right of the grid.
Find items from the same
This allows you to filter the items in the grid by Batch, Process Date, Company, or Group. The group option
only appears if you have 'Allow Grouping of items' turned on. Once the grid is filtered, you will also have
the option to 'Revert to last query'. This will remove the filter and show you all the items that were in the
grid before the filter was applied.
 
Properties
This will display all the data in the database for  the current item in the grid.



 

 

 



 

 

 
Copying data and images to other applications
You can copy the selected data  to the clipboard and paste it into many other applications such as

• Microsoft Word
• Microsoft Excel
• Microsoft Wordpad

To copy data in the grid select the items that you would like to copy and choose Edit>Copy or CTRL +C.

Choose Copy Data to the Clipboard from the Copy Dialog.
Then switch to the application to paste the data into and choose Edit>Paste or CTRL + V. This will paste
the data to the other application.
 
Excel Example



 

 

 
Word Example

 



 

 

You can also copy the image and paste it into many image editing applications such as

• Adobe Photoshop
• Microsoft Paint
• Microsoft Photo Editor
• Microsoft Word

 
To copy the current image in the grid  choose Edit>Copy or CTRL +C.

Choose Copy Image from the copy Dialog.
Switch to the application that you would like to copy the image to and choose Edit>Paste or CTRL + V
 
Word Example with image and data  pasted in the document

 
Paint Example



 

 



 

 

EZ-Scan.NET Options
 

 
The EZ-Scan users can be synced with the users in the EZWebview software by setting up the options on
the EZ-Scan.NET tab of the options screen.
 
EZ-Scan Options Database
Browse to locate the EZ-Scan options database.
 
Database description
Enter a description for the EZ-Scan.NET database.
 
Sync Users
Click the Sync Users button to synchronize the users with the EZ-Scan.NET database. The users will be
synced when clicking OK to save the options also.
 


	Table of Contents
	EZ-Scan 5.0 Help File
	Welcome to EZ-Scan
	Appendix
	END USER LICENSE AGREEMENT
	Installing Components
	Supported Scanners

	Custom Fields
	Add Fields
	Edit Fields

	Customer Support
	Customer Support
	Downloads

	Customize the Layout
	View Menu

	Data Verification
	Data Verification

	Database
	EZ-Scan SQL Server Setup Guide
	New Database Wizard

	Emailing Items
	Email

	Exporting Data
	ACH Export
	Check 21 Export
	Export Data Images
	EZ-Scan Database Export
	EZ-Scan Image Export
	EZ-Scan Text Export
	Configure

	Reliafund Export
	SER Check Export
	SER Doc Export
	XML Export

	Getting Started
	Quick Start Guide
	Quick Start Guide

	Startup Wizard
	StartupWizard

	Getting Started

	Importing Data
	Auto Import
	EZ-Scan Check 21 Import
	EZ-Scan Image Import
	EZ-Scan Opex Import
	Generic Text Import Wizard
	Import an EZ-Scan Database
	Ivory Import

	Locating Documents
	Finding Items

	Options
	Batch Fields Option Settings
	Export Option Settings
	General Option Settings
	Item Fields Option Settings
	Options
	Scanning Option Settings
	Security Option Settings
	Storage Option Settings

	Plug-Ins
	Plug-Ins
	PST Address Lookup Plug-In v1.0
	PST Barcode/OCR Plug-In v1.0
	PST CAR LAR Plug-In v1.0
	PST Check Recognition Plug-In v1.0
	PST Data Entry Plug-In v1.0
	PST Data Validation Plug-In v1.0
	PST Document Recognition Plug-In v1.0
	PST Image Validation Plug-In v1.0
	PST MICR OCR Plug-In v1.0
	PST OCR Mitek Plug-In v1.0
	PST Parsing Plug-In v1.0
	PST PDF Out Plug-In v1.0
	PST Sorting Plug-In v1.0
	PST Verify Template
	PST Virtual Encoder Plug-In v1.0
	PST Voice Verify Plug-In v1.0

	Printing Images
	Printing Items

	Reports
	Batch Detail Report
	Batch Detail Report Sample
	Batch Listing Report
	Batch Listing Report Sample
	Batch Summary Report
	Batch Summary Report Sample
	Grid Listing Report
	Reports
	Route Report

	Scanning
	Scanning Items
	MICR Masks

	Toolbar
	Toolbar

	Tools
	External Tools
	Eview21
	PST Database Viewer
	PST Image Viewer

	Activation Tool
	Compact The Database
	Image Relocator
	Purge Data
	Query Tool
	Storage Wizard

	Using the Grid
	Grid
	Editing


	EZ-Scan.NET Options


